欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

求某个范围内的所有素数

程序员文章站 2024-02-08 19:42:22
...

求某个范围内的所有素数

Problem Description

求小于n的所有素数,按照每行10个显示出来。

Input

输入整数n(n<10000)。

Output

每行10个依次输出n以内的所有素数。如果一行有10个素数,每个素数后面都有一个空格,包括每行最后一个素数。

Sample Input

100

Sample Output

2 3 5 7 11 13 17 19 23 29 
31 37 41 43 47 53 59 61 67 71 
73 79 83 89 97 

Hint

Source

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		int n = cin.nextInt();
		int count = 0;
		for(int i = 2;i <= n;++i)
		{
			if(isPrime(i)){
				System.out.print(i + " ");
				count++;
				if(count % 10 == 0)
				{
					System.out.println();
				}
			}
		}
	}

	private static boolean isPrime(int i) {
		boolean flag = true;
		for(int j = 2;j <= Math.sqrt(i);j++)
		{
			if(i % j==0)
			{
				flag = false;
			}
		}
		
		return flag;
	}

}