codevs1083 Cantor表(类似于蛇形矩阵吧)
程序员文章站
2024-01-13 20:13:46
...
现代数学的著名证明之一是Georg Cantor证明了有理数是可枚举的。他是用下面这一张表来证明这一命题的: 1/1 1/2 1/3 1/4 1/5 … 2/1 2/2 2/3 2/4 … 3/1 3/2 3/3 … 4/1 4/2 … 5/1 … … 我们以Z字形给上表的每一项编号。第一项是1/1,然后是1/2,2/1,3/1,2/2,…
输入描述 Input Description
整数N(1≤N≤10000000)
输出描述 Output Description
表中的第N项
样例输入 Sample Input
7
样例输出 Sample Output
1/4
向右、向左下、向下、向右上
其中可以定义左下和下是一趟,右上和右是一趟,观察可以得出奇数次趟是往左下走,而偶数趟是往右上走的,且第1趟斜着走1步,第2趟2步,第3趟3步……
#include <iostream>
#include<algorithm>
using namespace std;
int n;//读取编号
int num;//记录当前的编号
int row = 1, col = 1;//记录当前的行列号
int cirle = 0;//记录这是第几趟
int main()
{
cin >> n;
num = 1;//从编号为1开始
while (1)
{
for (int i=1;i<=cirle;i++)
{
if (num==n) break;
if (cirle % 2 == 1)
{//奇数趟往左下走
row++;
col--;
num++;
}
if (cirle % 2 == 0)
{//偶数趟往右上走
row--;
col++;
num++;
}
}
if (num==n) break;
if (cirle%2==0) col++;//偶数趟最后往由走
else row++;//奇数趟往下走
num++;
cirle++;//趟数增加
}
cout << row << "/" << col;
cin >> n;
return 0;
}