欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

codevs1011 数的计算

程序员文章站 2024-01-13 19:52:40
...

题目描述 Description

我们要求找出具有下列性质数的个数(包含输入的自然数n):

先输入一个自然数n(n<=1000),然后对此自然数按照如下方法进行处理:

1.          不作任何处理;

2.          在它的左边加上一个自然数,但该自然数不能超过原数的一半;

3.          加上数后,继续按此规则进行处理,直到不能再加自然数为止.

输入描述 Input Description

一个数n

输出描述 Output Description

满足条件的数的个数

样例输入 Sample Input

6

样例输出 Sample Output

6

数据范围及提示 Data Size & Hint

6个数分别是:

6

16

26

126

36

136


#include <iostream>
#include<algorithm>
using namespace std;
int n;
int counter = 0;

void judge(int x)
{
	if (x==1)
	{
		counter++;
		return;
	}
	counter++;
	for (int i=1;i<=x/2;i++)
		judge(i);
}

int main()
{
	cin >> n;
	judge(n);
	cout << counter;
	cin >> n;
	return 0;

}






相关标签: codevs