欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Hdoj 2669 Romantic

程序员文章站 2024-01-12 09:34:10
...

Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
…………………………..Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print “sorry” instead.

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0< a, b<=2^31)

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put “sorry” instead.

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

Author
yifenfei

Source
HDU女生专场公开赛——谁说女子不如男


题目分析
用扩展欧几里得算法解

Code

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cctype>
#include<cstring>
#include<cstdlib>
using namespace std;
typedef long long LL;
LL gcd(LL a,LL b)
{
    return b==0? a : gcd(b,a%b);
}//计算最大公约数
LL e_gcd(LL a,LL b,LL &x,LL&y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    LL d=e_gcd(b,a%b,x,y);
    LL t=x;
    x=y;
    y=t-a/b*y;
    return d;
}
int main() 
{
    LL a,b;
    while(cin>>a>>b)
    {
        if(gcd(a,b)!=1) cout<<"sorry\n";//有解的条件是a,b互质
        else
        {
            LL x,y;
            e_gcd(a,b,x,y);
            while(x<=0)
            {
                x+=b;
                y-=a;
            }
            cout<<x<<" "<<y<<endl;
        }
    }
    return 0;
}

更多问题请关注个人博客,不定时更新