POJ2312Battle City
程序员文章站
2023-12-24 12:37:03
...
易水人去,明月如霜。
Language:
Battle City
Description Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now.
What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there? Input The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target),
'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
Output For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
Sample Input 3 4 YBEB EERE SSTE 0 0 Sample Output 8 Source
POJ Monthly,鲁小石
|
题目背景就是小时候玩的坦克大战,求从起点到终点最少需要多少步。已知S和R是不能走得,E是空的,可以走,B是砖,只有打掉后才可以通过。
思路:很容易看出来是个搜索题目,我们可以发现可以走的不过的B和E,E的话直接走B的话打掉再走也就是说要走B的话STEP要加2
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
struct node {
int x,y,s;
friend bool operator <(node a,node b)
{
return a.s>b.s;
}
};
char map[305][305];
int n,m;
int vis[305][305];
int dir[][2]={
{0,1},{0,-1},{1,0},{-1,0}
};
int sx,sy,ex,ey;
bool ok(int x,int y)
{
if(x>=0&&x<n&&y>=0&&y<m&&(map[x][y]!='S'&&map[x][y]!='R'))
return true;
return false ;
}
int bfs()
{
priority_queue<node> q;
node head;
memset(vis,1,sizeof(vis));
head.x=sx,head.y=sy,head.s=0;
q.push(head);
vis[sx][sy]=0;
while(!q.empty())
{
node f=q.top();
q.pop();
if(f.x==ex&&f.y==ey)
return f.s;
for(int i=0;i<4;i++)
{
int dx=dir[i][0]+f.x,dy=f.y+dir[i][1];
if(ok(dx,dy)&&vis[dx][dy])
{
vis[dx][dy]=0;
int temp;
if(map[dx][dy]=='B') temp=2;
else temp=1;
node ss;
ss.x=dx,ss.y=dy,ss.s=f.s+temp;
q.push(ss);
}
}
}
return -1;
}
int main()
{
while(scanf("%d%d",&n,&m)&&n+m)
{
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
cin>>map[i][j];
if(map[i][j]=='Y') sx=i,sy=j;
else if(map[i][j]=='T') ex=i,ey=j;
}
}
printf("%d\n",bfs());
}
return 0;
}