欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

poj 1308 Is It A Tree?(并查集)

程序员文章站 2022-03-15 22:54:53
...

Is It A Tree?

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 34199 Accepted: 11597
Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
poj 1308 Is It A Tree?(并查集)
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output

For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input

6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


每个节点只有条有向边指向它,确定给出的集合满足树的定义。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 1111
#define inf 0x3f3f3f3f
int p[N], nod[2*N];
int a, b, root, n_m, flg, cas = 1;
int fnd( int x ) { return p[x] = p[x] == x ? x : fnd( p[x] ); }
bool same( int x, int y ) { return fnd(x) == fnd(y); }
void unit( int x, int y )
{
    int u = fnd( x );
    int v = fnd( y );
    if( u != v && (u != x && v != y )) flg = 1;
    if( u != v ){
        p[u] = y;
    }
}
int main()
{
    //freopen( "in.txt", "r", stdin );
    while( cas ){
        flg = n_m = 0;
        for( int i = 0 ; i < N ; i ++ ) p[i] = i;
        while( scanf( "%d%d", &a, &b ) != EOF ){
            if(( a == -1 && b == -1 ) || ( a == 0 && b == 0 )) break;
            nod[n_m++] = a;
            nod[n_m++] = b;
            if( same( b, a ) ) flg = 1;
            else unit( b, a );
        }
        if( a == -1 && b == -1 ) break;
        if( !flg ){
            sort( nod, nod+n_m );
            root = fnd( nod[0] );
            for( int i = 0 ; i < n_m ; i ++ ){
                if( fnd( nod[i] ) != root ) flg = 1;
            }
        }
        if( flg ) printf( "Case %d is not a tree.\n", cas ++ );
        else printf( "Case %d is a tree.\n", cas ++ );
    }
    return 0;
}