hdu 2602 Bone Collector
程序员文章站
2022-07-16 12:08:04
...
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
15 101 2 3 4 55 4 3 2 1
Sample Output
14
Author
Teddy
Source
重量可以为0
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int N=1000+5;
ll w[N];
ll v[N];
ll dp[N][N];
int main(){
int n;
scanf("%d",&n);
while(n--)
{
int a,b;
scanf("%d %d",&a,&b);
for(int i=1;i<=a;i++)
{
scanf("%lld",&v[i]);
}
for(int i=1;i<=a;i++)
{
scanf("%lld",&w[i]);
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=a;i++)
{
for(int j=0;j<=b;j++)
{
if(j<w[i])
{
dp[i][j]=dp[i-1][j];
}
else
{
dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+v[i]);
}
}
}
printf("%lld\n",dp[a][b]);
}
return 0;
}
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
typedef long long ll;
const int N=1000+5;
ll w[N];
ll v[N];
ll dp[N];
int main(){
int n;
scanf("%d",&n);
while(n--)
{
int a,b;
scanf("%d %d",&a,&b);
for(int i=1;i<=a;i++)
{
scanf("%lld",&v[i]);
}
for(int i=1;i<=a;i++)
{
scanf("%lld",&w[i]);
}
memset(dp,0,sizeof(dp));
for(int i=1;i<=a;i++)
{
for(int j=b;j>=w[i];j--)
{
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}
}
printf("%lld\n",dp[b]);
}
return 0;
}
吐槽一下csdn真难用
下一篇: P1094 纪念品分组