HDU3466 Proud Merchants 01背包 通过排序去除后效性
Proud Merchants
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 8234 Accepted Submission(s): 3457
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?
Input
There are several test cases in the input.
Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.
The input terminates by end of file marker.
Output
For each test case, output one integer, indicating maximum value iSea could get.
Sample Input
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
Sample Output
5 11
Author
iSea @ WHU
Source
2010 ACM-ICPC Multi-University Training Contest(3)——Host by WHU
因为每个物品都有一个限制q,而01背包dp是从前i个物品转移到前i+1个物品,所以必须保证转移时无后效性,即前面i个物品选择的结果不会影响到后面的选择,在这里体现在前i个物品中会影响的范围为q-p;如果第i+1个物品的q-p > 前i个物品的q-p,则可以保证如果选择第i个物品,那么前面i+1个物品的q的限制条件都能满足。 即 qi+1 在的位置>qi
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 510;
const int INF = 0x3f3f3f3f;
int n,m;
int dp[5005];
struct Node
{
int p,q,v;
}a[maxn];
bool cmp (Node a, Node b)
{
return a.q - a.p < b.q - b.p;
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i = 0; i < n; i++) scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
sort(a,a+n,cmp);
memset(dp,0,sizeof(dp));
for(int i = 0; i < n; i++)
for(int j = m; j >= a[i].q; j--)
dp[j] = max(dp[j],dp[j-a[i].p] + a[i].v);
printf("%d\n",dp[m]);
}
return 0;
}
上一篇: 1143.最长公共子序列
下一篇: 力扣课程表1-3 java实现