[pat乙级] 1054 求平均值
程序员文章站
2022-07-15 23:46:28
...
问题很简单,但是要判断的东西很多:
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出
ERROR: X is not a legal number
,其中X
是输入。最后在一行中输出结果:The average of K numbers is Y
,其中K
是合法输入的个数,Y
是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用Undefined
替换Y
。如果K
为 1,则输出The average of 1 number is Y
。输入样例 1:
7 5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number ERROR: 9999 is not a legal number ERROR: 2.3.4 is not a legal number ERROR: 7.123 is not a legal number The average of 3 numbers is 1.38
输入样例 2:
2 aaa -9999
输出样例 2:
ERROR: aaa is not a legal number ERROR: -9999 is not a legal number The average of 0 numbers is Undefined
注意 K == 1输出的是 number,而大于1时则输出的是 numbers 。
头文件<ctype.h>中定义了对字符串进行判断的函数,包括:
掌握isdigit(ch), islower(ch), isupper(ch), tolower(ch), toupper(ch)即可。
#include<bits/stdc++.h>
#include<cstdlib>
using namespace std;
int main()
{
char ch = 'A';
if(isupper(ch))
cout << ch << "是大写的" << endl;
ch = tolower(ch);
if(islower(ch))
cout << ch << "是小写的" << endl;
return 0;
}
运行截图为:
<stdlib.h>或者<cstdlib>中的atof(char str[])可以将字符串转换为浮点型。此外还有atoi()函数以及atol()函数。
其余的判断细节都在代码中体现:
#include<bits/stdc++.h>
using namespace std;
char str[101][101];
int N;
bool judge(char str[])
{
int i = 0;
if(str[0] == '-')
i++;
for(; str[i] && str[i] != '.'; i++)
{
if(!isdigit(str[i]))
return false;
}
if(str[i] == '.')
{
for(int j = i + 1;str[j]; j++)
{
if(!isdigit(str[j]) || j - i > 2)
return false;
}
}
double num = fabs(atof(str));
if(num > 1000)
return false;
else
return true;
}
void V()
{
int K = 0;
double total = 0;
for(int i = 0; i < N; i++)
{
if(!judge(str[i]))
printf("ERROR: %s is not a legal number\n", str[i]);
else
{
K++;
total += atof(str[i]);
}
}
if(K == 0)
printf("The average of 0 numbers is Undefined\n");
else if(K == 1)
printf("The average of 1 number is %.2f\n", total);
else
printf("The average of %d numbers is %.2f\n", K, total/K);
}
int main()
{
scanf("%d", &N);
for(int i = 0; i < N; i++)
{
scanf("%s", str[i]);
}
V();
return 0;
}
参考: