欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【注意点分析】1016 Phone Bills (25 分)

程序员文章站 2022-07-15 13:30:43
...

立志用最少的代码做最高效的表达


PAT甲级最优题解——>传送门


A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:
Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (MM:dd:HH:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:
For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:HH:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80


注意

如果某一个人虽然有账单,但是没有找到有效的通话记录,这个人不予输出

输入的一天内各个小时段的话费单位是美分/分钟,所以在计算的时候一个小时的话费应该是60*price[i],另外输出费用要按美元计算,所以要除以100,不妨在输入一天内各个小时段的话费时就直接进行除以100的操作

输出月、日、时、分都必须有两位数字不够的要在高位补0


#include<bits/stdc++.h>
using namespace std;
struct Time{//定义时间类
    int month,day,hour,minute,time,online=0;//月日时分信息、距0日0时0分的分钟数、指明这一时间是online还是offline
    bool operator <(const Time&t)const{//重载<运算符
        return this->time<t.time;
    }
};
double price[25];//存储一天内各个小时段的话费单位是美元/分钟
double compute(Time t,int day){//计算当前时间到day日0时0分所用话费
    double bill=0.0;
    for(int i=0;i<t.hour;++i)
        bill+=60*price[i];
    return bill+t.minute*price[t.hour]+price[24]*60*(t.day-day);
}
int main(){
    for(int i=0;i<24;++i){//读取一天内各个小时段的话费
        scanf("%lf",&price[i]);
        price[i]/=100.0;//化为美元
        price[24]+=price[i];
    }
    int N;
    scanf("%d",&N);
    map<string,set<Time>>bill;//存储每个人的名字和对应的话费时间
    for(int i=0;i<N;++i){//读取账单
        string s1,s2;
        Time t;
        cin>>s1;
        scanf("%d:%d:%d:%d",&t.month,&t.day,&t.hour,&t.minute);
        t.time=(t.day*24+t.hour)*60+t.minute;
        cin>>s2;
        if(s2=="on-line")
            t.online=1;
        bill[s1].insert(t);
    }
    for(auto i=bill.cbegin();i!=bill.cend();++i){//查找有效的话费记录并就算用时与话费并输出
        bool output=false;//该人的话费记录是否需要输出/是否有有效的话费记录
        double sumBill=0.0;//该人的话费总额
        for(auto j=(i->second).cbegin();j!=(i->second).cend();++j){//定义set的迭代器j
            auto jnext=j;//定义指向j指向的下一个对象的迭代器
            ++jnext;
            for(;jnext!=(i->second).cend()&&!(j->online&&!jnext->online);++j,++jnext);//查找有效的话费记录
            if(jnext!=(i->second).cend()){//如果查找到了
                if(!output){//还没有输出过姓名的月份进行输出,并通过修改output变量标明该人的话费记录需要输出
                    output=true;
                    printf("%s %02d\n",(i->first).c_str(),j->month);
                }
                printf("%02d:%02d:%02d %02d:%02d:%02d ",j->day,j->hour,j->minute,jnext->day,jnext->hour,jnext->minute);//输出话费账单起止时间
                int t=jnext->time-j->time;//计算话费
                double bill=compute(*jnext,j->day)-compute(*j,j->day);//计算话费账单用时
                sumBill+=bill;//加到话费总额上
                printf("%d $%.2f\n",t,bill);//输出
            }
        }
        if(output)//如果该人的话费记录需要输出,输出话费总额
            printf("Total amount: $%.2f\n",sumBill);
    }
    return 0;
}

耗时

【注意点分析】1016 Phone Bills (25 分)


痛苦难道是白忍受的吗?它应该使我伟大!       ——托马斯 • 曼