欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

PAT-A1041 Be Unique【散列】

程序员文章站 2022-07-15 11:02:58
...

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

实际上是数组散列的过程,输出第一个不重复的数字。使用map记录每个数字的重复次数,vector保存序列,然后从前往后遍历。

#include <iostream>
#include <vector>
#include <map>
using namespace std;
int main(){
	int n;
	scanf("%d",&n);
	int temp;
	map<int,int> time;
	vector<int> seq;
	while(n--){
		scanf("%d",&temp);
		time[temp]++;
		seq.push_back(temp);
	}
	int num=-1;
	for(int i=0;i<seq.size();i++){
		if(time[seq[i]]==1){
			num=seq[i];
			break;
		}
	}
	if(num==-1){
		cout<<"None";
	}
	else{
		cout<<num;
	}
return 0;
}

PAT-A1041 Be Unique【散列】