PAT-A1051 Pop Sequence【栈】
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
思路分析:
我们以3217564为例,一个容量为5的堆栈,因为入栈序列已经确定为1~7,按照下面的步骤思考:
我们用next指向将要入栈的元素(初始值next=1),要输出的元素为x:
x=3,next=1,还没有压到3,要输出3,必须一直压到3,然后弹出3,此时next=4(下一次要压入的是4),堆栈现在从底到顶分别为12。
接下来x=2,next=4,已经无法通过压入元素到达x,因此只有栈顶为x时才可能得到要求的输出序列,这时候判断栈顶是不是x,不是则这个序列无法实现,是则继续判断下一个x。
同样地,x=1也是这样处理,我们发现堆栈中有12,正好输出为21,因此可以正确输出321。
下面x=7,next=4,一直压入到x再弹出,则next=7,堆栈中在弹出7后为456。
下面x=5,next=7,这时候又要判断栈顶是不是5了,发现栈顶是6,已经不可能得到要求的输出序列。
通过这样举例,抽象如下:
①如果当前想要输出的元素x>将要入栈的元素next(由入栈序列得到,从1开始),则一直压入到x,每压一次,next++;
②如果当前想要输出的元素x==栈顶元素,pop即可,注意,如果栈为空,需要压入一个元素,next++;continue
③如果当前想要输出的元素x<栈顶元素,此时不可能达到输出序列。直接break
#include <iostream>
#include <vector>
#include <string>
#include <stack>
#include <algorithm>
using namespace std;
int main(){
int n,m,k;
scanf("%d %d %d",&n,&m,&k);
int next=1;
bool flag=true;
stack<int> s;
int temp;
vector<int> show;
while(k--){
flag=true;
while(!s.empty()){
s.pop();
}
next=1;
s.push(next);
next++;
show.clear();
for(int i=0;i<m;i++){
scanf("%d",&temp);
show.push_back(temp);
}
for(int j=0;j<m;j++){
temp=show[j];
while(temp>s.top()){
s.push(next);
next++;
}
if(s.size()>n){
flag=false;
break;
}
if(temp==s.top()){
s.pop();
if(s.empty()){
s.push(next);
next++;
}
continue;
}
if(temp<s.top()){
flag=false;
break;
}
}
if(flag==true){
cout<<"YES"<<endl;
}else{
cout<<"NO"<<endl;
}
}
return 0;
}
推荐阅读
-
php array_pop()数组函数将数组最后一个单元弹出(出栈)
-
java用两个栈实现队列的push和pop
-
PAT-A1051 Pop Sequence【栈】
-
C++实现用两个栈来实现一个队列,完成队列的Push和Pop操作。 队列中的元素为int类型
-
实现一个栈,要求pop,push,Min,时间复杂度为O(1)
-
算法————双栈实现队列、双队列实现栈、实现一个栈Push(出栈)Pop(入栈)Min(返回最小值的操作)的时间复杂度为O(1)
-
CALL框架 pull pop EBP寄存器 栈底指针 ESP寄存器 栈顶指针
-
02-线性结构4 Pop Sequence
-
Pop Sequence
-
php array_pop()数组函数将数组最后一个单元弹出(出栈)