HDU2700-Parity
Parity
Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of
0's does not affect the parity of a bit string.
Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.
Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').
Sample Input
101e
010010o
1e
000e
110100101o
#
Sample Output
1010
0100101
11
0000
1101001010
#include<bits/stdc++.h>///1001
using namespace std;
int main()
{
int l,a;
char s[50];
while(scanf("%s",s),s[0]!='#')
{
a=0;
l=strlen(s);
for(int i=0;i<l-1;i++)
{
if(s[i]=='1')a++;
}
if(s[l-1]=='e')
{
if(a%2==0)
s[l-1]='0';
else
s[l-1]='1';
}
else
{
if(a%2==0)
s[l-1]='1';
else
s[l-1]='0';
}
printf("%s\n",s);
}
return 0;
}
上一篇: LeetCode 204. Count Primes
下一篇: Vim 配置以及插件管理
推荐阅读