欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU6447 数状数组+离散化

程序员文章站 2022-07-13 12:07:27
...

YJJ's Salesman

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1021    Accepted Submission(s): 340


 

Problem Description

YJJ is a salesman who has traveled through western country. YJJ is always on journey. Either is he at the destination, or on the way to destination.
One day, he is going to travel from city A to southeastern city B. Let us assume that A is (0,0) on the rectangle map and B (109,109). YJJ is so busy so he never turn back or go twice the same way, he will only move to east, south or southeast, which means, if YJJ is at (x,y) now (0≤x≤109,0≤y≤109), he will only forward to (x+1,y), (x,y+1) or (x+1,y+1).
On the rectangle map from (0,0) to (109,109), there are several villages scattering on the map. Villagers will do business deals with salesmen from northwestern, but not northern or western. In mathematical language, this means when there is a village k on (xk,yk) (1≤xk≤109,1≤yk≤109), only the one who was from (xk−1,yk−1) to (xk,yk) will be able to earn vk dollars.(YJJ may get different number of dollars from different village.)
YJJ has no time to plan the path, can you help him to find maximum of dollars YJJ can get.

 

 

Input

The first line of the input contains an integer T (1≤T≤10),which is the number of test cases.

In each case, the first line of the input contains an integer N (1≤N≤105).The following N lines, the k-th line contains 3 integers, xk,yk,vk (0≤vk≤103), which indicate that there is a village on (xk,yk) and he can get vk dollars in that village.
The positions of each village is distinct.

 

 

Output

The maximum of dollars YJJ can get.

 

 

Sample Input

 

1

3

1 1 1

1 2 2

3 3 1

 

 

Sample Output

 

3


官方做法


HDU6447 数状数组+离散化

/*
树状数组+离散化
按x从小到大排序x相同时y从大到小排序
把y离散化
x从小到大访问到达一个村庄时从y-1中取一个最大值
更新答案最后输出最大值
*/

 

#include<cstring>
#include<cstdio>
#include<iostream>
#include<string>
#include<queue>
#include<vector>
#include<algorithm>
#include<cmath>
#include<set>
#include<map>
using namespace std;
#define MAX_N 100000+5
#define MAX_M 100000+5
#define inf 0x3f3f3f3f3f
#define clr(a,b)     memset(a,b,sizeof(a))
#define lowbit(x)    x&-x
#define init    ios::sync_with_stdio(false); cin.tie();cout.tie()
typedef long long ll;

struct Node
{
    int x,y,w;
    void input()
    {
        scanf("%d%d%d",&x,&y,&w);
    }
    bool operator<(const Node &a)const{
        if(x == a.x) return y > a.y;
        return x < a.x;
    }
}node[MAX_N];
int n,y[MAX_N];
ll tree[MAX_N];
void update(int k,ll w)
{
    while(k<=n)
    {
        tree[k]=max(w,tree[k]);
        k+=lowbit(k);
    }
    return ;
}
ll  query(int k)
{
    ll ans=0;
    while(k>0)
    {
        ans=max(ans,tree[k]);
        k-=lowbit(k);
    }
    return ans;
}
int main() {
     int t;
     scanf("%d",&t);
     while(t--)
     {
         clr(node,0);
         clr(y,0);
         clr(tree,0);
         scanf("%d",&n);
         for(int i=1;i<=n;i++)
         {
             node[i].input();
             y[i]=node[i].y;
         }
         sort(y+1,y+1+n);
         sort(node+1,node+1+n);
         ll res=0;
         for(int i=1;i<=n;i++)
         {
             int k=lower_bound(y+1,y+1+n,node[i].y)-y;
             ll tmp=node[i].w+query(k-1);
             res=max(tmp,res);
             update(k,tmp);
         }
         printf("%lld\n",res);
     }
	return 0;
}