HDU - 1331 Function Run Fun 记忆化搜索
程序员文章站
2022-07-12 08:54:14
...
We all love recursion! Don't we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
InputThe input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result. Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1
if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)
if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)
otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)
This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.
OutputPrint the value for w(a,b,c) for each triple. Sample Input
1 1 1 2 2 2 10 4 6 50 50 50 -1 7 18 -1 -1 -1Sample Output
w(1, 1, 1) = 2 w(2, 2, 2) = 4 w(10, 4, 6) = 523 w(50, 50, 50) = 1048576 w(-1, 7, 18) = 1
一个超级水的记忆化搜索,然而,然而。。。。。。。。
我WA了几次,一脸懵逼,请注意第一个条件和第二个条件的先后顺序,原本以为一样手贱先写了大于20的判断,后来发现不一样,比如说w(-1,50,50),而题目的 意思是想让你先按照小于0,天天debug
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int d[21][21][21];
int w(int a,int b,int c){
if(a<=0||b<=0||c<=0){
return 1;
}
if(a>20||b>20||c>20){
if(d[20][20][20]!=-1){
return d[20][20][20];
}else{
d[20][20][20] = w(20,20,20);
return d[20][20][20];
}
}
if(a<b&&b<c){
if(d[a][b][c-1]==-1){
d[a][b][c-1] = w(a,b,c-1);
}
if(d[a][b-1][c-1]==-1){
d[a][b-1][c-1] = w(a,b-1,c-1);
}
if(d[a][b-1][c]==-1){
d[a][b-1][c] = w(a,b-1,c);
}
return d[a][b][c-1]+d[a][b-1][c-1]-d[a][b-1][c];
}else{
if(d[a-1][b][c]==-1){
d[a-1][b][c] = w(a-1, b, c);
}
if(d[a-1][b-1][c]==-1){
d[a-1][b-1][c] = w(a-1, b-1, c);
}
if(d[a-1][b][c-1]==-1){
d[a-1][b][c-1] = w(a-1, b, c-1);
}
if(d[a-1][b-1][c-1]==-1){
d[a-1][b-1][c-1] = w(a-1, b-1, c-1);
}
return d[a-1][b][c] + d[a-1][b-1][c] + d[a-1][b][c-1] - d[a-1][b-1][c-1];
}
}
int main(){
int a,b,c;
memset(d,-1,sizeof(d));
while(scanf("%d%d%d",&a,&b,&c)&&(a!=-1||b!=-1||c!=-1)){
printf("w(%d, %d, %d) = %d\n",a,b,c,w(a,b,c));
}
}
上一篇: 股票的最大利润