poj 1080 Human Gene Functions
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20313 | Accepted: 11333 |
Description
A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.
A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.
Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.
For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:
AGTGAT-G
-GT--TAG
In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.
denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.
Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):
AGTGATG
-GTTA-G
This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.
Input
Output
Sample Input
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
Sample Output
14 21
题意:根据表上给的分值,给你两个字符串,让你判断能获得的最大分数是多少
思路:理解LCS的dp写法的话,LCS中dp[i][j] 表示比较到第一个字符串的第i个位置和第二个字符串的第j个位置时,相同的子序列的最大长度
因此可以设dp[i][j]为取s1第i个字符,s2第j个字符时的最大分值
则决定dp为最优的情况有三种(score[][]为s1[i]和s2[j]两符号的分数):
1、 s1取第i个字母,s2取“ - ”: dp[i-1][j]+score[ s1[i-1] ]['-'];
2、 s1取“ - ”,s2取第j个字母:dp[i][j-1]+score['-'][ s2[j-1] ];
3、 s1取第i个字母,s2取第j个字母:dp[i-1][j-1]+score[ s1[i-1] ][ s2[j-1] ];
即dp[i][j]=max( dp[i-1][j]+score[ s1[i-1] ]['-'],
dp[i][j-1]+score['-'][ s2[j-1] ],
dp[i-1][j-1]+score[ s1[i-1] ][ s2[j-1] ] );
注意初始化
不仅仅只有
dp[0][0] = 0
也不仅仅是
dp[0][0] = 0
dp[1][0] = score[ s1[i-1] ]['-']
dp[0][1] = score['-'][ s2[j-1] ]
必须全面考虑到所有情况,
当i=j=0时,dp[i][j]=0
当i=0时,dp[0,j] = dp[0][j-1] + score['-'][ s2[j-1] ]
当j=0时,dp[i,0] = dp[i-1][0] + score[ s1[i-1] ]['-']
ac代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf = -5;
int score['T'+5]['T'+5];
int dp[105][105];
char str1[105];
char str2[105];
//打表
void initial(void)
{
score['A']['A']=5;
score['C']['C']=5;
score['G']['G']=5;
score['T']['T']=5;
score['-']['-']=inf;
score['A']['C']=score['C']['A']=-1;
score['A']['G']=score['G']['A']=-2;
score['A']['T']=score['T']['A']=-1;
score['A']['-']=score['-']['A']=-3;
score['C']['G']=score['G']['C']=-3;
score['C']['T']=score['T']['C']=-2;
score['C']['-']=score['-']['C']=-4;
score['G']['T']=score['T']['G']=-2;
score['G']['-']=score['-']['G']=-2;
score['T']['-']=score['-']['T']=-1;
return;
}
int getmax(int a,int b,int c)
{
int k = (b>c?b:c);
return a>k?a:k;
}
int main()
{
initial();
int t;
scanf("%d",&t);
while(t--)
{
int len1,len2;
memset(dp,0,sizeof(dp));
memset(str1,'\0',sizeof(str1));
memset(str2,'\0',sizeof(str2));
scanf("%d",&len1);
cin>>str1;
scanf("%d",&len2);
cin>>str2;
dp[0][0] = 0;
for(int i = 1; i <= len1; i++)
{
dp[i][0] = dp[i-1][0] + score[str1[i-1]]['-'];
}
for(int j = 1; j <= len2; j++)
dp[0][j] = dp[0][j-1] + score['-'][str2[j-1]];
for(int i = 1; i <= len1; i++)
{
for(int j = 1; j <= len2; j++)//取分数最大的值
{
dp[i][j] += getmax(dp[i][j-1] + score['-'][str2[j-1]],dp[i-1][j]+score[str1[i-1]]['-'],dp[i-1][j-1]+score[str1[i-1]][str2[j-1]]);
}
}
cout<<dp[len1][len2]<<endl;
}
return 0;
}
上一篇: HDU 1331(Function Run Fun)
下一篇: 股票的最大利润
推荐阅读
-
hdu 1080 Human Gene Functions 很霸气的DP
-
【poj1080】 Human Gene Functions
-
【POJ 1080】 Human Gene Functions
-
poj1080 Human Gene Functions
-
POJ 1080 Human Gene Functions
-
【POJ1080】Human Gene Functions(动态规划)
-
poj 1080 Human Gene Functions
-
POJ 1080 Human Gene Functions
-
poj1080 Human Gene Functions (lcs变形)
-
hdu 1080 Human Gene Functions