欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

简单字符串排序------ASCII码排序(HDJO)

程序员文章站 2022-07-08 22:21:00
...

题目地址:http://acm.hdu.edu.cn/showproblem.php?pid=2000
Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。

Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。

Output
对于每组输入数据,输出一行,字符中间用一个空格分开。

Sample Input
qwe
asd
zxc

Sample Output
e q w
a d s
c x z

#include <iostream>
#include <string>
#include<cstring>
#include<algorithm>
using namespace std;
int main(){
    string b;
    while(cin>>b)//多组循环输入
    {
      sort(b.begin(),b.end());//字符串排序
      for(int i=0;i<3;i++)
     {
         if(i==2)
         cout<<b[i];
         else
         cout<<b[i]<<" ";
  }
        cout<<endl;
    }
       return 0;
}