欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

hdu 5015 矩阵快速幂

程序员文章站 2022-07-03 21:59:07
...

233 Matrix

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2722    Accepted Submission(s): 1572


Problem Description
In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a0,1 = 233,a0,2 = 2333,a0,3 = 23333...) Besides, in 233 matrix, we got ai,j = ai-1,j +ai,j-1( i,j ≠ 0). Now you have known a1,0,a2,0,...,an,0, could you tell me an,m in the 233 matrix?
 

Input
There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 109). The second line contains n integers, a1,0,a2,0,...,an,0(0 ≤ ai,0 < 231).
 

Output
For each case, output an,m mod 10000007.
 

Sample Input

1 1 1 2 2 0 0 3 7 23 47 16
 

Sample Output

234 2799 72937
Hint
hdu 5015 矩阵快速幂
题意:构建一个矩阵 啊a(0,0) = 0; a(n,0)由键盘输入 a(0,1)=233 a(0,2)=2333 a(0,3)=23333......; a(i,j)=a(i-1.j)+a(i,j-1)
求a(n,m)
很典型的一个矩阵快速幂的题
最重要的是推导出快速幂的矩阵

思路:

第一列元素为:

0

a1

a2

a3

a4

转化为:

23

a1

a2

a3

a4

3

则第二列为:

23*10+3

23*10+3+a1

23*10+3+a1+a2

23*10+3+a1+a2+a3

23*10+3+a1+a2+a3+a4

3

根据前后两列的递推关系,有等式可得矩阵A的元素为hdu 5015 矩阵快速幂
其中a(0,0)=23
ac代码
#include<iostream>
#include<cstdio>
#include<cstring>
#define MOD 10000007
using namespace std;

typedef long long LL;

int n,m;
//矩阵结构体
struct Mat
{
    LL mat[15][15];
};
//乘法模板
Mat operator*(Mat a,Mat b)
{
        Mat c;
        memset(c.mat,0,sizeof(c.mat));
        for(int k = 0; k < n+2;k++)
            for(int i = 0; i < n+2; i++)
            for(int j = 0; j < n+2; j++)
            c.mat[i][j] = (c.mat[i][j] + a.mat[i][k]*b.mat[k][j])%MOD;
        return c;
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        Mat sum,temp;
        memset(sum.mat,0,sizeof(sum.mat));
        memset(temp.mat,0,sizeof(temp.mat));
        sum.mat[0][0] = 23;
        sum.mat[n+1][0] = 3;
        for(int i = 1; i < n+1; i++)
            scanf("%lld",&sum.mat[i][0]);
        if(m == 0)
        {
            if(n == 0)
            printf("0\n");
            else
                printf("%lld\n",sum.mat[n][0]);
        }
        else
        {
            //构建快速幂矩阵
            for(int i = 1; i <= n; i++)
            {
                for(int j = 1; j <= i; j++)
                {
                    temp.mat[i][j] = 1;
                }
            }
            for(int i = 0; i < n+2; i++)
                temp.mat[i][0] = 10;
            for(int i = 0; i < n+2; i++)
                temp.mat[n+1][i] = 0;
              for(int i = 0; i < n+2; i++)
                temp.mat[i][n+1] = 1;
            Mat res;
            memset(res.mat,0,sizeof(res.mat));
            for(int i = 0; i < n+2; i++)
                res.mat[i][i] = 1;
                //m次方
            while(m>0)
            {
                if(m&1)
                    res = res*temp;
                temp = temp*temp;
                m/=2;
            }
        sum = res*sum;//特别注意这里  是和res相乘
            printf("%lld\n",sum.mat[n][0]);
        }
    }
    return 0;
}