HDU 1757-A Simple Math Problem(矩阵快速幂)
address : http://acm.hdu.edu.cn/showproblem.php?pid=1757
Problem Description
Lele now is thinking about a simple function f(x).
If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .
Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
Output
For each case, output f(k) % m in one line.
Sample Input
10 9999
1 1 1 1 1 1 1 1 1 1
20 500
1 0 1 0 1 0 1 0 1 0
Sample Output
45
104
做了 好几道矩阵快速幂题了, 这道题矩阵一眼就看出了,但 这个矩阵有点有点大 我也不想画了,就摘了温学姐 博客一张图片
敬上:
矩阵 挺好推得这个 计算这个 矩阵的 k-9 次幂 然后乘下 f(0) 到f(9) 即可
模板题 我几乎都用现在个 模板了
code:
#include <iostream>
#include <bits/stdc++.h>
using namespace std;
struct node
{
int m[10][10];
}ans,a;
int k, m;
node mul(node ans, node a)
{
node p;
memset(p.m, 0, sizeof(p.m));
for(int i = 0; i < 10; i++) ///i行
for(int j = 0; j < 10; j++) ///j列
for(int k = 0; k < 10; k++)
p.m[i][j] = (p.m[i][j]+ans.m[i][k]*a.m[k][j])%m;
return p;
}
void solve(int k)
{
memset(ans.m, 0, sizeof(ans.m));
for (int i=0; i<10; i++)
{
ans.m[i][i] = 1;
}
while (k)
{
if (k&1)
ans = mul(ans, a);
a = mul(a, a);
k>>=1;
}
}
int main()
{
while (~scanf("%d%d",&k,&m))
{
memset(a.m, 0, sizeof(a.m));
for (int i=0 ; i<10; i++)
{
cin>>a.m[0][i];
a.m[0][i] = a.m[0][i]%m;
}
for (int i=1; i<10; i++)
a.m[i][i-1] = 1;
if (k<10)
cout<<k<<endl;
else
{
k = k-9;
solve(k);
int show=0;
for (int i=0; i<10; i++)
{
show = (show+ans.m[0][i]*(9-i))%m;
}
cout<<show<<endl;
}
}
return 0;
}
上一篇: 常用对话框的使用
下一篇: 050使用文件对话框