【笨方法学PAT】1061 Dating (20 分)
一、题目
Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm
. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04
-- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D
, representing the 4th day in a week; the second common character is the 5th capital letter E
, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A
to N
, respectively); and the English letter shared by the last two strings is s
at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM
, where DAY
is a 3-character abbreviation for the days in a week -- that is, MON
for Monday, TUE
for Tuesday, WED
for Wednesday, THU
for Thursday, FRI
for Friday, SAT
for Saturday, and SUN
for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
二、题目大意
给出四个字符串,前两个字符串确定日期和小时, 后两个字符串确定分钟。
三、考点
string
四、注意
1、题目很简单,但容易弄混乱,要一个个耐心处理;
2、处理的过程中,记得break。
五、代码
#include<iostream>
#include<string>
using namespace std;
int main() {
//read
string s1, s2, s3, s4;
getline(cin, s1), getline(cin, s2), getline(cin, s3), getline(cin, s4);
string s[7] = { "MON","TUE","WED","THU","FRI","SAT","SUN" };
//first
int i;
for (i = 0; i < s1.length() && i < s2.length(); ++i) {
if (s1[i] == s2[i] && s1[i]>='A'&&s1[i]<='G') {
cout << s[s1[i] - 'A'] << " ";
break;
}
}
//second
for (i = i + 1; i < s1.length() && i < s2.length(); ++i) {
if (s1[i] == s2[i]) {
if (isdigit(s1[i])) {
printf("%02d", s1[i] - '0');
break;
}
else if (s1[i] >= 'A'&&s1[i] <= 'N') {
printf("%02d", s1[i] - 'A' + 10);
break;
}
}
}
//third
for (int i = 0; i < s3.length() && i < s4.length(); ++i) {
if (s3[i] == s4[i] && isalpha(s3[i]))
printf(":%02d", i);
}
system("pause");
return 0;
}
本文地址:https://blog.csdn.net/linghugoolge/article/details/83305620
下一篇: 赵匡义为什么要改名?真相是什么