7-32 说反话-加强版 (20 分)
程序员文章站
2022-03-10 21:48:38
...
7-32 说反话-加强版 (20 分)
给定一句英语,要求你编写程序,将句中所有单词的顺序颠倒输出。
输入格式:
测试输入包含一个测试用例,在一行内给出总长度不超过500 000的字符串。字符串由若干单词和若干空格组成,其中单词是由英文字母(大小写有区分)组成的字符串,单词之间用若干个空格分开。
输出格式:
每个测试用例的输出占一行,输出倒序后的句子,并且保证单词间只有1个空格。
输入样例:
Hello World Here I Come
输出样例:
Come I Here World Hello
AC代码
[放松的方式]
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <string.h>
using namespace std;
int main()
{
stack<char> st;
string str;
getline(cin,str);
int i,len=str.length(),fir=1;
for (i=len-1;i>=0;i--){
if(str[i]==' ' && !st.empty()){
if(fir)
fir=0;
else
printf(" ");
while(!st.empty()){
printf("%c",st.top());
st.pop();
}
}
if(str[i]!=' ')
st.push(str[i]);
}
if(!st.empty()){
if(fir)
fir=0;
else
printf(" ");
while(!st.empty()){
printf("%c",st.top());
st.pop();
}
}
///printf("***");
return 0;
}
下一篇: MySQL 链接参数说明