1152 Google Recruitment (20分)
题目
In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.
Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.
Input Specification:
Each input file contains one test case. Each case first gives in a line two positive integers: and , which are the numbers of digits of the given number and the prime to be found, respectively. Then the -digit number is given in the next line.
Output Specification:
For each test case, print in a line the first -digit prime in consecutive digits of . If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.
Sample Input 1:
20 5
23654987725541023819
Sample Output 1:
49877
Sample Input 2:
10 3
2468024680
Sample Output 2:
404
题目大意
从长整数中取出位数,顺序从左到右,要求求出第一个k位数为质数的数;
思路
刚开始问了优化,直接判断当时,尾数为0、2、4、5、6、8的直接过滤,但是忽略了这样一种情况,这个k位数为0002,像这样的情况就不能采用上述的优化策略,索性直接不优化了,哈哈;
代码
#include <cstdio>
#include <iostream>
#include <string>
#include <cmath>
using namespace std;
bool check(int n){
if(n < 2)
return false;
for(int i=2; i<=sqrt(n); i++)
if(n%i == 0)
return false;
return true;
}
int main(){
int l, k;
string str;
scanf("%d%d", &l, &k);
cin>>str;
if(l < k)
printf("404\n");
else{
bool flag = false;
string subtr;
for(int i=k; i<=l; i++){
subtr = str.substr(i-k, k);
int t = 0;
for(int j=0; j<k; j++)
t = t*10+(subtr[j]-'0');
if(check(t)){
flag = true;
break;
}
}
if(flag)
printf("%s\n", subtr.c_str());
else
printf("404\n");
}
return 0;
}
推荐阅读
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20 分)
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20分)
-
1152 Google Recruitment (20 分)
-
1152 Google Recruitment (20 分)
-
1152 Google Recruitment (20分)