基础实验 4-2.1 树的同构(25 分)
程序员文章站
2022-06-07 21:44:16
...
给定两棵树 T1 和 T2。如果 T1 可以通过若干次左右孩子互换就变成 T2,则我们称两棵树是“同构”的。例如图 1 给出的两棵树就是同构的,因为我们把其中一棵树的结点 A、B、G 的左右孩子互换后,就得到另外一棵树。而图 2 就不是同构的。
现给定两棵树,请你判断它们是否是同构的。
输入格式:
输入给出 2 棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数 N(≤10),即该树的结点数(此时假设结点从 0 到 N−1 编号);随后 N 行,第 i 行对应编号第 i 个结点,给出该结点中存储的 1 个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。
输出格式:
如果两棵树是同构的,输出“Yes”,否则输出“No”。
输入样例 1(对应图 1):
8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
输出样例 1:
Yes
输入样例 2(对应图 2):
8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
输出样例 2:
No
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
char letter,lefts,rights,father;
}treef[16],trees[16];
int compare(node first,node second){
return first.letter<second.letter;
}
int main(){
int nodef,nodes,i;
scanf("%d",&nodef);
for(i=0;i<nodef;i++)scanf("\n%c %c %c",&treef[i].letter,&treef[i].lefts,&treef[i].rights);
scanf("%d",&nodes);
for(i=0;i<nodes;i++)scanf("\n%c %c %c",&trees[i].letter,&trees[i].lefts,&trees[i].rights);
for(i=0;i<nodef;i++){
if(treef[i].lefts!='-')treef[treef[i].lefts-'0'].father=treef[i].letter;
if(treef[i].rights!='-')treef[treef[i].rights-'0'].father=treef[i].letter;
}
for(i=0;i<nodes;i++){
if(trees[i].lefts!='-')trees[trees[i].lefts-'0'].father=trees[i].letter;
if(trees[i].rights!='-')trees[trees[i].rights-'0'].father=trees[i].letter;
}
sort(treef,treef+nodef,compare);
sort(trees,trees+nodes,compare);
for(i=1;i<nodef;i++)if(treef[i].father!=trees[i].father){
printf("No");
return 0;
}
if(treef[0].letter!=trees[0].letter)printf("No");
else printf("Yes");
return 0;
}