2018中国大学生程序设计竞赛 - 网络选拔赛 1003 Dream(hdu 6440)(费马小定理)
程序员文章站
2022-06-07 12:09:13
...
题目链接hdu 6440 Dream
Sample Input
1
2
Sample Output
0 1
1 0
0 0
0 1
题意:重新定义+和*运算,要求小于p的m和n,满足,p为素数
思路:题意比较难懂,但是如果想到了费马小定理,代码是很简单的
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
int main(){
int t;
scanf("%d",&t);
while(t--){
int p;
scanf("%d",&p);
for(int i=1;i<=p;i++){
for(int j=1;j<=p;j++){
printf("%d ",((i-1)+(j-1))%p);
}
printf("\n");
}
for(int i=1;i<=p;i++){
for(int j=1;j<=p;j++){
printf("%d ",((i-1)*(j-1))%p);
}
printf("\n");
}
}
return 0;
}
上一篇: Python爬虫抓取智联招聘(基础版)
下一篇: 步骤条 - 标签页