欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1072 Gas Station 图的遍历dijkstra

程序员文章站 2022-06-07 11:42:27
...

1072 Gas Station (30 分)
A gas station has to be built at such a location that the minimum distance between the station and any of the residential housing is as far away as possible. However it must guarantee that all the houses are in its service range.

Now given the map of the city and several candidate locations for the gas station, you are supposed to give the best recommendation. If there are more than one solution, output the one with the smallest average distance to all the houses. If such a solution is still not unique, output the one with the smallest index number.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: N (≤10
​3
​​ ), the total number of houses; M (≤10), the total number of the candidate locations for the gas stations; K (≤10
​4
​​ ), the number of roads connecting the houses and the gas stations; and D
​S
​​ , the maximum service range of the gas station. It is hence assumed that all the houses are numbered from 1 to N, and all the candidate locations are numbered from G1 to GM.

Then K lines follow, each describes a road in the format

P1 P2 Dist
where P1 and P2 are the two ends of a road which can be either house numbers or gas station numbers, and Dist is the integer length of the road.

Output Specification:
For each test case, print in the first line the index number of the best location. In the next line, print the minimum and the average distances between the solution and all the houses. The numbers in a line must be separated by a space and be accurate up to 1 decimal place. If the solution does not exist, simply output No Solution.

Sample Input 1:
4 3 11 5
1 2 2
1 4 2
1 G1 4
1 G2 3
2 3 2
2 G2 1
3 4 2
3 G3 2
4 G1 3
G2 G1 1
G3 G2 2
Sample Output 1:
G1
2.0 3.3
Sample Input 2:
2 1 2 10
1 G1 9
2 G1 20
Sample Output 2:
No Solution
1072 Gas Station 图的遍历dijkstra

  • fill(e[0],e[0]+1015*1015);

  • string p1,p2;如果char要注意p1[1015],p2[1015];

#include<iostream>
#include<cstdio>
using namespace std;
const int INF=0xFFFFFFF;
int n,m,K,Ds;
string p1,p2;
int p3;
int e[1015][1015];
int dis[1015];
bool vis[1015];
int toint(string s)
{
	int res=0;
	if(s[0]=='G')
	{
		res=s[1]-'0';
		if(s[2])res=res*10+s[2]-'0';
		res+=n;
	}
	else
	{
		int l=s.length();
		for(int i=0;i<l;i++)
		{
			res=res*10+s[i]-'0';
		}
	}
	return res;
}
int main()
{
	scanf("%d%d%d%d",&n,&m,&K,&Ds);
	fill(e[0],e[0]+1015*1015,INF);
	for(int i=0;i<K;i++)
	{
		cin>>p1>>p2>>p3;//
		int a=toint(p1);
		int b=toint(p2);
		e[a][b]=e[b][a]=p3;
	}
	int Fmind=-1;
	double Ave=INF,ave;
	int ans=-1;
	for(int i=n+1;i<=n+m;i++)//计算m个起点 
	{
		fill(vis,vis+1015,0);
		fill(dis,dis+1015,INF);
		dis[i]=0;
		for(int j=1;j<=n+m;j++)
		{
			int u=0,minn=INF;
			for(int k=1;k<=n+m;k++)
			{
				if(!vis[k]&&dis[k]<minn)
				{
					u=k;minn=dis[k];
				}
			}
			if(!u) break;/////////
			vis[u]=1;
			for(int k=1;k<=n+m;k++)
			{
				p3=dis[u]+e[u][k];
				if(!vis[k]&&p3<dis[k])
				{
					dis[k]=p3;
				}
			}
		}
		/*judge if station is out Ds*/
		/*and count ave*/
		ave=0;
		int mindis=INF;
		for(int j=1;j<=n;j++)
		{
			if(dis[j]>Ds)
			{
				mindis=-1;
				break;
			}
			if(dis[j]<mindis)mindis=dis[j];
			ave+=dis[j];
		}
		if(mindis==-1)continue;
		ave=ave/(double)n;
		/**/
		if(mindis>Fmind)
		{
			Fmind=mindis;
			Ave=ave;
			ans=i;
		}
		else if(mindis==Fmind)
		{
			if(ave<Ave)
			{
				Ave=ave;
				ans=i;
			}
			else if(ave==Ave)
			{
				ans=min(ans,i);
			}
		}
	}
	if(ans==-1)
	printf("No Solution\n");
	else
	{
		printf("G%d\n",ans-n);
		printf("%.1f %.1f\n",(double)Fmind,Ave);
	}
	return 0;
}