HDU2602——Bone Collector【01背包问题】
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output
14
Author
Teddy
Source
HDU 1st “Vegetable-Birds Cup” Programming Open Contest
Recommend
lcy | We have carefully selected several similar problems for you: 1203 2159 2955 1171 2191
01背包模版题。
#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int MAXN=1010;
int dp[MAXN],w[MAXN],v[MAXN];//容量对应的最大价值,单个物品的价值,物品的体积
int main(){
int t;
cin>>t;
while(t--){
int n,s;
cin>>n>>s;
memset(dp,0,sizeof(dp));
for(int i=1;i<=n;i++) cin>>w[i];
for(int i=1;i<=n;i++) cin>>v[i];
for(int i=1;i<=n;i++){
for(int j=s;j>=v[i];j--){
dp[j]=max(dp[j],dp[j-v[i]]+w[i]);
}
}
printf("%d\n",dp[s]);
}
return 0;
}
上一篇: 数值分析Python实现系列—— 一、拉格朗日插值法
下一篇: [C++]STL-stack容器