7-14 电话聊天狂人 (25分) (map)C++
程序员文章站
2022-06-07 09:46:28
...
给定大量手机用户通话记录,找出其中通话次数最多的聊天狂人。
输入格式:
输入首先给出正整数N(≤105),为通话记录条数。随后N行,每行给出一条通话记录。简单起见,这里只列出拨出方和接收方的11位数字构成的手机号码,其中以空格分隔。
输出格式:
在一行中给出聊天狂人的手机号码及其通话次数,其间以空格分隔。如果这样的人不唯一,则输出狂人中最小的号码及其通话次数,并且附加给出并列狂人的人数。
输入样例:
4
13005711862 13588625832
13505711862 13088625832
13588625832 18087925832
15005713862 13588625832
输出样例:
13588625832 3
思路:unordered_map用来记录每一个电话号码出现的次数,然后最后把最大值找出来,把最大值的人数也找出来,进行比较,输出。
#include<bits/stdc++.h>
#include <unordered_map>
using namespace std;
int main()
{
int n,i,k,count=0; cin>>n;
unordered_map<string,int> hash;
vector<string> out;
for(i=0;i<n;i++)
{
string c1,c2;
cin>>c1>>c2;
hash[c1]++;
hash[c2]++;
k=hash[c1]>hash[c2]?hash[c1]:hash[c2];
}
unordered_map<string,int>::iterator iter;
iter = hash.begin();
while(iter != hash.end()) {
if(k==iter->second)
{
out.push_back(iter->first);
count++;
}
iter++;
}
if(count==1){
for(auto x:out)
cout<<x<<" "<<k;
}
else{
sort(out.begin(),out.end());
cout<<out[0]<<" "<<k<<" "<<count;
}
return 0;
}