欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

HDU——2136(素数筛法) Largest prime factor

程序员文章站 2022-06-04 18:44:40
...

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=2136

HDU——2136(素数筛法) Largest prime factor
测试样例

Sample Input
1
2
3
4
5
Sample Output
0
1
2
1
3

题意: 给你一个整数 n n n,求它的最大质因子在素数表中的位置。

解题思路: 对于这种大量求素数问题,我们必然是使用素数筛,这里使用埃式筛法。当然我们由于是要确定素数表的位置。故我们需要对埃式筛法进行一定的改进。即当我们发现一个素数后,我们需要记录它的位置。并将它的所有倍数都变为它的位置。(这样我们确定的时候直接索引即可获取最大质因子数的位置了,因为我们打表是往后推进的。) 故此题易解。

AC代码

/*
*邮箱:aaa@qq.com
*blog:https://me.csdn.net/hzf0701
*注:文章若有任何问题请私信我或评论区留言,谢谢支持。
*
*/
#include<bits/stdc++.h>	//POJ不支持

#define rep(i,a,n) for (int i=a;i<=n;i++)//i为循环变量,a为初始值,n为界限值,递增
#define per(i,a,n) for (int i=a;i>=n;i--)//i为循环变量, a为初始值,n为界限值,递减。
#define pb push_back
#define IOS ios::sync_with_stdio(false);cin.tie(0); cout.tie(0)
#define fi first
#define se second
#define mp make_pair

using namespace std;

const int inf = 0x3f3f3f3f;//无穷大
const int maxn = 1e6+2;//最大值。
typedef long long ll;
typedef long double ld;
typedef pair<ll, ll>  pll;
typedef pair<int, int> pii;
//*******************************分割线,以上为自定义代码模板***************************************//

int n;
int primer[maxn];
void isprimer(){
	int index=0;
	rep(i,2,maxn){
		if(!primer[i]){
			index++;
			primer[i]=index;
			for(int j=2;j*i<=maxn;j++){
				primer[i*j]=index;
			}
		}
	}
}
int main(){
	//freopen("in.txt", "r", stdin);//提交的时候要注释掉
	IOS;
	isprimer();
	while(cin>>n){
		cout<<primer[n]<<endl;
	}
	return 0;
}