C++_学生成绩统计_类的应用
本题主要介绍setprecision()保留双精度浮点型数据小数点位数的控制
Problem Description
通过本题目练习可以掌握对象数组的用法,主要是对象数组中数据的输入输出操作。
设计一个学生类Student 它具有私有的数据成员:学号、姓名、数学成绩、英语成绩、计算机成绩;具有公有的成员函数:求三门课总成绩的函数int sum(); 求三门课平均成绩的函数 double average(); 输出学生基本信息、总成绩和平均成绩的函数 void print(); 设置学生数据信息的函数void set_stu_info(int n,char *p,int m,int e,int c)。
请编写主函数,建立学生对象数组,从键盘输入一组学生数据,输出学生的成绩统计表:
stuID 姓名 数学 英语 计算机 总成绩 平均成绩
001 xxx 90 85 95 270 90.0
002 yyy 95 98 92 285 95.0
Input
输入数据有5行,代表5个学生的信息。
每行有5个数据,数据间用一个空格分隔,分别代表学生的学号、姓名、数学成绩、英语成绩和计算机成绩。除了姓名是符号串外,其他均为整型数据,数据在int类型范围内。
Output
输出数据一共有7行。
第一行输出提示信息“Input the messages of five students(StudentID Name Math English Computer )”
第二行输出一个空行,进行输入输出间的间隔
第三行输出表头“StuID Name Math Eng Com Total Average” ,这一行有7个数据,数据间用制表符’\t’分隔,分别代表学生的学号、姓名、数学成绩、英语成绩、计算机成绩、总成绩和平均成绩。其中平均成绩为实型数据,保留1位小数。
第4-8行分别输出5个学生的相关数据。每个数据占一个制表符的空间。格式同上。
Sample Input
1001 Andy 89 90 93
1002 Mary 93 95 98
1003 Luis 90 85 98
1004 Sam 91 95 98
1005 Lily 87 98 99
Sample Output
Input the messages of five students(StudentID Name Math English Computer )
StuID Name Math Eng Com Total Average
1001 Andy 89 90 93 272 90.7
1002 Mary 93 95 98 286 95.3
1003 Luis 90 85 98 273 91.0
1004 Sam 91 95 98 284 94.7
1005 Lily 87 98 99 284 94.7
Hint
Source
黄晶晶
#include<iostream>
#include<string.h>
#include<iomanip>
using namespace std;
class Student
{
public:
int sum()
{
return m+e+c;
}
double average()
{
return (m+e+c)/3.0; //*3.0而不是3是为了将结果强制转化为double类型
}
void print()
{
int s = sum();
double a = average();
cout<<n<<"\t"<<p<<"\t"<<m<<"\t"<<e<<"\t"<<c<<"\t"<<s<<"\t"<<setprecision(1)<<fixed<<a<<endl;
///setprecision(n)是存在于iomanip库中的类, n和fixed表示小数点后保留n位
}
void set_stu_info(int n_, char p_[], int m_, int e_, int c_)
{
n = n_;
strcpy(p,p_);
m = m_;
e = e_;
c = c_;
}
private:
int n;
char p[20];
int m;
int e;
int c;
}Stu[5];
int main()
{
cout<<"Input the messages of five students(StudentID Name Math English Computer )"<<endl;
int n;
char p[20];
int m;
int e;
int c;
cout<<endl;
for(int i=0; i<5; i++)
{
cin>>n>>p>>m>>e>>c;
Stu[i].set_stu_info(n, p, m, e, c);
}
cout<<"StuID"<<"\t"<<"Name"<<"\t"<<"Math"<<"\t"<<"Eng"<<"\t"<<"Com"<<"\t"<<"Total"<<"\t"<<"Average"<<endl;
for(int i=0; i<5; i++)
{
Stu[i].print();
}
return 0;
}
上一篇: CSS3教程之制作倾斜导航条和毛玻璃效果
下一篇: 微信小程序开发UI框架如何使用