欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

【HDU 1215】 七夕节 唯一分解定理 素数 数论

程序员文章站 2022-06-02 12:38:54
...

七夕节那天,月老来到数字王国,他在城门上贴了一张告示,并且和数字王国的人们说:“你们想知道你们的另一半是谁吗?那就按照告示上的方法去找吧!”
人们纷纷来到告示前,都想知道谁才是自己的另一半.告示如下:

【HDU 1215】 七夕节 唯一分解定理 素数 数论

数字N的因子就是所有比N小又能被N整除的所有正整数,如12的因子有1,2,3,4,6.
你想知道你的另一半吗?

Input
输入数据的第一行是一个数字T(1<=T<=500000),它表明测试数据的组数.然后是T组测试数据,每组测试数据只有一个数字N(1<=N<=500000).

Output
对于每组测试数据,请输出一个代表输入数据N的另一半的编号.

Sample Input
3
2
10
20

Sample Output
1
8
22

题意:计算n以内(不包括n)的所有因子和

思路(唯一分解定理):

看很多博客讲的是线性筛,我第一眼看觉得是唯一分解定理的板子,而且n不大,就直接用这个了。就直接套公式:
Ans = (q10+q11+q12 …q1a1(q20+q21+q22…q2a2…*(qn0+qnn+qn2…qnan
其中qix代表第i个分解素数的x次方因子,括号里面每一项都是等比数列求和,由 积性函数性质可知每项之间的求和后乘积即为最终结果。最后注意Ans-n就好,因为题目要求因子不能等于n

AC代码:

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include <queue>
#include <time.h>
#include <stack>
#include<vector>
#define FAST ios::sync_with_stdio(false)
#define abs(a) ((a)>=0?(a):-(a))
#define sz(x) ((int)(x).size())
#define all(x) (x).begin(),(x).end()
#define mem(a,b) memset(a,b,sizeof(a))
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
#define rep(i,a,n) for(int i=a;i<=n;++i)
#define per(i,n,a) for(int i=n;i>=a;--i)
#define pb push_back
#define mp make_pair
#define fi first
#define se second
#define maxn 100000+500
using namespace std;
typedef pair<int,int> PII;
typedef long long ll;
const int maxm = 100000+5;
const int inf=0x3f3f3f3f;
const double eps = 1e-7;
const double pi=acos(-1);
const int mod = 1e18+7;
inline int lowbit(int x){return x&(-x);}
ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
void ex_gcd(ll a,ll b,ll &d,ll &x,ll &y){if(!b){d=a,x=1,y=0;}else{ex_gcd(b,a%b,d,y,x);y-=x*(a/b);}}//x=(x%(b/d)+(b/d))%(b/d);
inline ll qpow(ll a,ll b,ll MOD){ll res=1;a%=MOD;while(b>0){if(b&1)res=res*a%MOD;a=a*a%MOD;b>>=1;}return res;}
inline ll inv(ll x,ll p){return qpow(x,p-2,p);}
inline ll Jos(ll n,ll k,ll s=1){ll res=0;rep(i,1,n+1) res=(res+k)%i;return (res+s)%n;}
inline ll read(){ ll x = 0;char ch = getchar();while(ch>'9'||ch<'0') ch = getchar();while(ch>='0'&&ch<='9') x = (x<<3) + (x<<1) + ch - '0',  ch = getchar();return x; }
ll n;
void solve()
{
    ll ans = 1;
    ll t = n;
    for(ll i=2;i*i<=n;i++)
    {
        if(n%i==0)
        {
            ll tmp = 0;
            ll p = i;
            while(n%i==0)       //唯一分解定理,求出每项的等比数列和
            {
                tmp += p;
                p *= i;
                n /= i;
            }
            tmp += 1;       //加上1这个元素,也就是p的零次方
            ans *= tmp;
        }
    }
   if(n > 1) ans *= (1 + n);        //剩下的肯定是一个质数(若大于1),那就算上1和它本身
    cout<<ans-t<<endl;      //最后要减去本身,题目要求是小于它的因子
}

int main()
{
    int kase;
    cin>>kase;
    while(kase--)
    {
       cin>>n;
       solve();
    }
    return 0;
}