1122 Hamiltonian Cycle(25 分)
The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
#include<cstdio>
#include<fstream>
#include<cstring>
#include<vector>
#include<set>
using namespace std;
const int maxn=210;
int n, m;
int g[maxn][maxn]={0};
int main(){
// freopen("d://in.txt", "r", stdin);
scanf("%d%d", &n, &m);
for(int i=0; i<m; i++){
int u, v;
scanf("%d%d", &u, &v);
g[u][v]=g[v][u]=1;
}
int k;
scanf("%d", &k);
for(int i=0; i<k; i++){
int len;
scanf("%d", &len);
int ans[len+1]={0};
set<int> s;
for(int j=0; j<len; j++){
scanf("%d", &ans[j]);
s.insert(ans[j]);
}
int x=ans[0];
bool flag=true;
if(x!=ans[len-1] || len!=n+1 || s.size()!=n) flag=false;
for(int j=0; j<len-1; j++){
int a=ans[j];
int b=ans[j+1];
if(g[a][b]!=1){
flag=false;
break;
}
}
if(flag==true) printf("YES\n");
else printf("NO\n");
s.clear();
}
return 0;
}
推荐阅读
-
PAT 甲级 1122. Hamiltonian Cycle (25)
-
【PAT】1122. Hamiltonian Cycle (25)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
A1122 Hamiltonian Cycle (25 分| 图论,附详细注释,逻辑分析)
-
PAT 1122 Hamiltonian Cycle
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT甲级 1122. Hamiltonian Cycle (25)
-
1122 Hamiltonian Cycle (25 分)
-
1122 Hamiltonian Cycle (25 分)