1122 Hamiltonian Cycle (25 分)
1122 Hamiltonian Cycle (25 分)
The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
题目大意:给出一个图,判断给定的路径是不是哈密尔顿路径
分析:
1.如果节点多走、少走、或走成环,则输出NO
2.如果这条路不能走通,则输出NO.
3.最后剩下的就一定是哈密尔顿路径,输出YES。
#include <iostream>
#include <vector>
#include <set>
using namespace std;
int e[300][300], n, m;
vector<int> v;
void check(int index) {
int k;
cin >> k;
vector<int> v(k);
set<int> s;
for(int i = 0; i < k; i++) {
scanf("%d", &v[i]);
s.insert(v[i]);
}
if( s.size() != n || k - 1 != n || v[0] != v[k-1] ){
printf("NO\n");
return ;
}
for(int i = 0; i < k - 1; i++)
if( e[v[i]][v[i+1]] == 0) {
printf("NO\n");
return ;
}
printf("YES\n");
}
int main() {
scanf("%d%d", &n, &m);
for ( int i = 0; i < m; i++) {
int t1, t2, t;
scanf("%d%d", &t1, &t2);
e[t1][t2] = e[t2][t1] =1;
}
int k;
scanf("%d", &k);
for ( int i = 1; i <= k; i++)
check(i);
return 0;
}
推荐阅读
-
PAT 甲级 1122. Hamiltonian Cycle (25)
-
【PAT】1122. Hamiltonian Cycle (25)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
A1122 Hamiltonian Cycle (25 分| 图论,附详细注释,逻辑分析)
-
PAT 1122 Hamiltonian Cycle
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT甲级 1122. Hamiltonian Cycle (25)
-
1122 Hamiltonian Cycle (25 分)
-
1122 Hamiltonian Cycle (25 分)