1122 Hamiltonian Cycle (25 分)
The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2
, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 ... Vn
where n is the number of vertices in the list, and Vi's are the vertices on a path.
Output Specification:
For each query, print in a line YES
if the path does form a Hamiltonian cycle, or NO
if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
int n, m, k;
int graph[210][210] = { 0 };
set<int> s;
int main() {
cin >> n >> m;
for (int i = 0; i < m; i++) {
int t1, t2;
scanf("%d%d", &t1, &t2);
graph[t1][t2] = graph[t2][t1] = 1;
}
cin >> k;
for (int i = 0; i < k; i++) {
int tmp;
scanf("%d", &tmp);
bool flag = 0;
int st;
s.clear();
for (int j = 0; j < tmp; j++) {
int v[1010];
int t3;
scanf("%d", &t3);
v[j] = t3;
if (j == 0) st = t3;
else {
if (j != tmp - 1) {
if (s.find(t3) != s.end() && flag == 0) {
flag = 1;
printf("NO\n");
}
}
else {
if (t3 != st && flag == 0) {
flag = 1;
printf("NO\n");
}
}
if (graph[v[j - 1]][v[j]] == 0 && flag == 0) {
flag = 1;
printf("NO\n");
}
}
s.insert(t3);
}
if (tmp != n + 1 && flag == 0) printf("NO\n");
else if (flag == 0 && tmp == n + 1) printf("YES\n");
}
return 0;
}
推荐阅读
-
PAT 甲级 1122. Hamiltonian Cycle (25)
-
【PAT】1122. Hamiltonian Cycle (25)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
A1122 Hamiltonian Cycle (25 分| 图论,附详细注释,逻辑分析)
-
PAT 1122 Hamiltonian Cycle
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT甲级 1122. Hamiltonian Cycle (25)
-
1122 Hamiltonian Cycle (25 分)
-
1122 Hamiltonian Cycle (25 分)