欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

1122. Hamiltonian Cycle (25)

程序员文章站 2022-03-01 13:37:14
...

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

C++:

/*
 @Date    : 2018-03-02 09:44:15
 @Author  : 酸饺子 ([email protected])
 @Link    : https://github.com/SourDumplings
 @Version : $Id$
*/

/*
https://www.patest.cn/contests/pat-a-practise/1122
 */

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

static int N, M;
static const int MAXN = 201;
static bool G[MAXN][MAXN];
static bool checked[MAXN];

int main(int argc, char const *argv[])
{
    scanf("%d %d", &N, &M);
    int v, w;
    for (int i = 0; i != N; ++i)
        for (int j = 0; j != N; ++j)
            G[i][j] = false;
    while (M--)
    {
        scanf("%d %d", &v, &w);
        G[v-1][w-1] = G[w-1][v-1] = true;
    }
    int K;
    scanf("%d", &K);
    while (K--)
    {
        int n;
        scanf("%d", &n);
        int path[n];
        for (int i = 0; i != n; ++i)
            scanf("%d", &path[i]);
        bool ok = false;
        if (n == N + 1 && path[N] == path[0])
        {
            ok = true;
            fill(checked, checked+N, false);
            for (int i = 0; i != N; ++i)
            {
                if (!G[path[i]-1][path[i+1]-1] || checked[path[i]-1])
                {
                    ok = false;
                    break;
                }
                checked[path[i]-1] = true;
            }
        }
        if (ok) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}