欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

寒假训练(并查集)

程序员文章站 2022-05-22 13:37:03
...

HDU1213

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4

问题简介:告诉你有多少朋友,谁认识谁,有共同朋友的坐一桌,问要多少桌。
问题分析:并查集问题

#include <iostream>
using namespace std;
int pre[1001],zuozi;
int find(int x)//查找共同朋友
{
	if (pre[x] != x)pre[x] = find(pre[x]);
	return pre[x];
}
void hebing(int x, int y)//将认识的人合并到一个集合
{
	int a = find(x); int b = find(y);
	if (a != b) { pre[a] = b; zuozi--; }
}
int main()
{
	int t; cin >> t;
	while (t--)
	{
		int n, m, x, y;
		cin >> n >> m;
		for (int i = 0; i <= n; i++)pre[i] = i;
		zuozi = n;
		for (int i = 1; i <= m; i++)
		{
			cin >> x >> y; hebing(x, y);
		}
		cout << zuozi << endl ;
	}
}