1122. Hamiltonian Cycle (25)
1122. Hamiltonian Cycle (25)
时间限制 300 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序
Standard 作者 CHEN, Yue
The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format “Vertex1 Vertex2”, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 … Vn
where n is the number of vertices in the list, and Vi’s are the vertices on a path.
Output Specification:
For each query, print in a line “YES” if the path does form a Hamiltonian cycle, or “NO” if not.
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
using namespace std;
const int MaxN = 210;
int N, M;
bool G[MaxN][MaxN];
int main() {
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG
std::ios::sync_with_stdio(false);
cin >> N >> M;
for (int i = 1; i <= N; ++i)G[i][i] = true;
for (int i = 1; i <= M; ++i) {
int u, v; cin >> u >> v;
G[u][v] = G[v][u] = true;
}
int Q; cin >> Q;
for (int i = 0; i < Q; ++i) {
int n, u, last, oldu;
bool passed = true;
cin >> n >> u; last = oldu = u;
int isTra[MaxN] = { 0 }; isTra[last] = true;
while (--n) {
cin >> last;
if (G[oldu][last] == false) {
passed = false;
}
++isTra[last];
oldu = last;
}
if (!passed || last != u) {
cout << "NO\n";
continue;
}
int idx = 1;
while (idx <= N) {
if (isTra[idx] == 0 || isTra[idx] > 2)break;
if (isTra[idx] == 2 && idx != u)break;
++idx;
}
if (idx > N)cout << "YES\n";
else cout << "NO\n";
}
return 0;
}
推荐阅读
-
PAT 甲级 1122. Hamiltonian Cycle (25)
-
【PAT】1122. Hamiltonian Cycle (25)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
A1122 Hamiltonian Cycle (25 分| 图论,附详细注释,逻辑分析)
-
PAT 1122 Hamiltonian Cycle
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT甲级 1122. Hamiltonian Cycle (25)
-
1122 Hamiltonian Cycle (25 分)
-
1122 Hamiltonian Cycle (25 分)