【PAT】1122. Hamiltonian Cycle (25)【模拟】
题目描述
The “Hamilton cycle problem” is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a “Hamiltonian cycle”.
In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.
翻译:“哈密顿环问题”是寻找一个包含图中每个顶点的简单循环。这样的循环称为“哈密顿环”。
在这个问题中,你要判断一个给定的循环是否是一个哈密顿循环。
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:
n V1 V2 … Vn
where n is the number of vertices in the list, and Vi’s are the vertices on a path.
翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括两个正整数N(2<N≤200), 表示顶点的数量,和M,表示一个无向图中边的条数。接下来M行, 每行按照 Vertex1 Vertex2的格式描述一条边,顶点被标记为1到N。接下来一行给定一个正整数K,表示查询的数量,接着按照以下格式给出K组查询:
n V1 V2 … Vn
n表示顶点的个数,Vi表示路径上的节点数。
Output Specification:
For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.
翻译:对于每个查询,如果是一个哈密顿环,则输出一行YES,否则输出NO。
Sample Input:
6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1
Sample Output:
YES
NO
NO
NO
YES
NO
解题思路
这道题不用想得太复杂,就是路径开始和结束相同,包含所有顶点且除起点外每个顶点只出现一次,如果这两个条件满足在计算每相邻的两个点之间是否有边,如果没有直接退出循环。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M,K;
bool v[210][210];
int dot[210];
int main(){
memset(v,0,sizeof(v));
scanf("%d%d",&N,&M);
int a,b;
for(int i=0;i<M;i++){
scanf("%d%d",&a,&b);
v[a][b]=v[b][a]=true;
}
scanf("%d",&K);
for(int i=0;i<K;i++){
memset(dot,0,sizeof(dot));
int n,flag=0;
scanf("%d",&n);
if(n!=N+1)flag=1;
int first=0,pre=0,pro=0;
for(int j=0;j<n;j++){
scanf("%d",&pro);
dot[pro]++;
if(dot[pro]>1&&j!=n-1) flag=1;
if(j==n-1&&pro!=first) flag=1;
if(!flag){
if(j==0) first=pre=pro;
else {
if(v[pre][pro]!=true)flag=1;
pre=pro;
}
}
}
if(flag==1)printf("NO\n");
else printf("YES\n");
}
return 0;
}
上一篇: 1122. Hamiltonian Cycle (25) 图论 23'
下一篇: Mapping
推荐阅读
-
PAT 甲级 1122. Hamiltonian Cycle (25)
-
【PAT】1122. Hamiltonian Cycle (25)
-
PAT甲1122 Hamiltonian Cycle(25 分)
-
[Python](PAT)1122 Hamiltonian Cycle(25 分)
-
A1122 Hamiltonian Cycle (25 分| 图论,附详细注释,逻辑分析)
-
PAT 1122 Hamiltonian Cycle
-
PAT (Advanced Level) Practice - 1122 Hamiltonian Cycle(25 分)
-
PAT甲级 1122. Hamiltonian Cycle (25)
-
PAT(A)1078 Hashing (25分)(模拟哈希表,二次查找防重复)
-
1122 Hamiltonian Cycle (25 分)