欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

邻接表(邻接图)

程序员文章站 2022-05-21 16:14:01
...

1.题目引入:

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

2.样例输出: 

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题目大意:从 1 点出发到达各处并返回问需要最少的价格。

显然本题需要进行两次遍历,且因为点数很多需要从邻接表储存改图。 

3.代码如下: 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
const int N=1e7;
const int inf=0x3f3f3f3f;
int top;
struct dd
{
	int to,w,next;
}d[N+5];
int head[N+5],n,m;
long long dis[N+5];
int a1[N+5],a2[N+5],c[N+5];
void dfs(int u,int v,int w)   //以邻接表的形式储存 
{
	d[top].to=v;
	d[top].w=w;
	d[top].next=head[u];   //编号为top的边的下一条边 
	head[u]=top++;         //保存顶点u的第一条边的编号 
}
long long bfs()
{
	memset(dis,inf,sizeof(dis));
	queue<int>q;
	q.push(1);    //从 1 开始 
	dis[1]=0;     //初始化 在 1时为零 
	while(!q.empty())
	{
		int u=q.front();
		q.pop();
		for(int i=head[u];i!=-1;i=d[i].next)
		{
			int v=d[i].to;
			if(dis[v]>dis[u]+d[i].w)   
			{
				dis[v]=dis[u]+d[i].w;
				q.push(v);
			}
		}
	}
	long long res=0;
	for(int i=1;i<=n;i++)
	{
		res+=dis[i];          //到达 各i点 时相加即可 
	}
	return res;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
	top=0;
	scanf("%d%d",&n,&m);
	memset(head,-1,sizeof(head));
	for(int i=0;i<m;i++)
	{
		scanf("%d%d%d",&a1[i],&a2[i],&c[i]);
		dfs(a1[i],a2[i],c[i]);
	}
	long long ans=bfs();
	memset(head,-1,sizeof(head));
	for(int i=0;i<m;i++)
	{
		dfs(a2[i],a1[i],c[i]);
	}
	ans+=bfs();
	printf("%lld\n",ans);
	}
	return 0;
}