A - 迷宫问题 保存路径
程序员文章站
2022-05-21 11:51:30
...
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include <iostream>
#include <cstdio>
#include <stack>
#include <cstring>
using namespace std;
struct node{
int x;
int y;
}p;
stack<node> mi_n,temp,im;
int map[6][6];
bool book[6][6];
int mm=30;
int net[4][2]={1,0,0,1,-1,0,0,-1};
void dfs(int x,int y,int step){
if(x==5&&y==5){
//cout<<step<<endl;
if(step<mm){
mm=step;
while(!mi_n.empty()) mi_n.pop();
im=temp;
for(int i=1;i<=mm+1;i++){
mi_n.push(im.top());
im.pop();
}
}
}
for(int i=0;i<=3;i++){
//cout<<x<<" "<<y<<endl;
int dx=x+net[i][0];
int dy=y+net[i][1];
if(dx<1||dy<1||dx>5||dy>5) continue;
if(map[dx][dy]==1||book[dx][dy]==1) continue;
book[dx][dy]=1;
p.x=dx,p.y=dy;
temp.push(p);
dfs(dx,dy,step+1);
book[dx][dy]=0;
temp.pop();
}
}
int main(){
for(int i=1;i<=5;i++){
for(int j=1;j<=5;j++)
scanf("%d",&map[i][j]);
}
book[1][1]=1;
p.x=1,p.y=1;
temp.push(p);
dfs(1,1,0);
while(!mi_n.empty()){
printf("(%d, %d)\n",mi_n.top().x-1,mi_n.top().y-1);
mi_n.pop();
}
return 0;
}