欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

POJ 3984 迷宫问题

程序员文章站 2022-05-20 22:52:15
...

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output

左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

广搜。

#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
using namespace std;
#define sf scanf
#define pf printf
#define mt(a) memset(a,0,sizeof a)

const int maxn = 6;
const int inf=0x3f3f3f3f;
typedef long long ll;
int gcd(int a, int b){return b?gcd(b,a%b):a;}
typedef unsigned long long ull;

template<class T>inline void read(T&num){
	num=0;T f=1;char ch=getchar();
	while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
	while(ch>='0'&&ch<='9')num=num*10+ch-'0',ch=getchar();
	num*=f;
}
int sqr(int x) {return x * x;}
void chmin(int &a, int b) {a = (a < b ? a : b);}
void chmax(int &a, int b) {a = (a > b ? a : b);}


int dir[4][2] = {0 , 1 , 0 , -1 , 1 , 0 , -1 , 0 };
int xi,yi,xt,yt,m;
int ma1p[maxn][maxn];
int vis[maxn][maxn];
struct node
{
    int x,y;
    int pre;
}Lujin[1000];
bool bfs()
{
        for(int i = 0;i < 5;i++)
            for(int j = 0;j < 5;j++)
            read(ma1p[i][j]);
            //scanf("%d",&ma1p[i][j]);
        mt(vis);
        int i = 0,j = 0;
        Lujin[0].x = Lujin[0].y = 0,Lujin[i++].pre = -1;
        vis[0][0] = 1;
        while(j < i)
        {
            for(int z = 0;z < 4;z++)
            {
                int dx = Lujin[j].x + dir[z][0];
                int dy = Lujin[j].y + dir[z][1];
                if(dx >=0 && dx < 5 && dy >= 0 && dy < 5)
                {
                    if(!vis[dx][dy] && !ma1p[dx][dy])
                    {
                        Lujin[i].x = dx,Lujin[i].y = dy;
                        Lujin[i].pre = j;
                        vis[dx][dy] = 1;
                        if(dx == xt && dy == yt)
                        {
                            m = i;
                            return true;
                        }
                        i++;
                    }
                }
            }
            j++;
        }
        return false;
}

int main()
{
    xi = yi = 0,xt = yt = 4;
    bfs();
    int k = m;
    int tmp;
    do
    {
        tmp = k;
        k = Lujin[k].pre;
        Lujin[tmp].pre = -1;
    }while(k);
    k = 0;
    while(k <= m)
    {
        if(Lujin[k].pre == -1)
            printf("(%d,%d)\n",Lujin[k].x,Lujin[k].y);
        k++;
    }
}
相关标签: POJ BFS