POJ2386 Lake Counting 深搜
Description
Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.
Given a diagram of Farmer John's field, determine how many ponds he has.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output
* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
Sample Output
3
Hint
OUTPUT DETAILS:
There are three ponds: one in the upper left, one in the lower left,and one along the right side.
题意:大小为N*M的菜园,雨后积起水,求出菜园*有多少水洼。
分析:从任意的‘W’开始进行DFS,不断把邻接的部分用'.'代替,1次DFS后与初始这个w连接的所有w就全都被替换成'.',因此直到图中不再存在W为止,总共进行DFS的次数就是答案。8个方向对应8个状态转移,每个格子作为DFS的参数最多调用一次,因此时间复杂度为O(8xNxM)=O(NM)。
#include<iostream>
using namespace std;
const int maxn=100;
char field[maxn][maxn];
int N,M;
void dfs(int x,int y)
{
field[x][y]='.';
for(int dx=-1;dx<=1;dx++)
for(int dy=-1;dy<=1;dy++){
int nx=x+dx,ny=y+dy;
if(nx>=0&&nx<N&&ny>=0&&ny<M&&field[nx][ny]=='W'){
dfs(nx,ny);
}
}
}
int main()
{
int ans=0;
cin>>N>>M;
for(int i=0;i<N;i++){
scanf("%s",field+i);
}
for(int i=0;i<N;i++)
for(int j=0;j<M;j++){
if(field[i][j]=='W'){
dfs(i,j);
ans++;
}
}
cout<<ans<<endl;
return 0;
}
上一篇: 417. 太平洋大西洋水流问题
下一篇: 77. 组合