POJ2255 ZOJ1944 UVA536 Tree Recovery【二叉树遍历】
程序员文章站
2022-05-19 19:51:04
...
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 16156 | Accepted: 9954 |
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
This is an example of one of her creations:
D / \ / \ B E / \ \ / \ \ A C G / / F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG BCAD CBAD
Sample Output
ACBFGED CDAB
Source
问题链接:POJ2255 ZOJ1944 UVA536 Tree Recovery
问题简述:
根据输入的前序遍历和中序遍历的字符串,求其后序遍历的结果。
问题分析:
这是一个树的遍历问题,用递归调用实现。
程序说明:(略)
题记:(略)
参考链接:(略)
AC的C++语言程序如下:
/* POJ2255 ZOJ1944 UVA536 Tree Recovery */
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
const int N = 26;
char s1[N + 1], s2[N + 1];
void bulid(int n, char s1[], char s2[])
{
if(n > 0) {
int p = strchr(s2, s1[0]) - s2;
bulid(p, s1 + 1, s2);
bulid(n - p - 1, s1 + p + 1, s2 + p + 1);
printf("%c", s1[0]);
}
}
int main()
{
while(scanf("%s %s", s1, s2) != EOF) {
int n = strlen(s1);
bulid(n, s1, s2);
printf("\n");
}
return 0;
}