set
7:Set
查看 提交 统计 提问
总时间限制: 5000ms 内存限制: 100000kB
描述
现有一整数集(允许有重复元素),初始为空。我们定义如下操作:
add x 把x加入集合
del x 把集合中所有与x相等的元素删除
ask x 对集合中元素x的情况询问
对每种操作,我们要求进行如下输出。
add 输出操作后集合中x的个数
del 输出操作前集合中x的个数
ask 先输出0或1表示x是否曾被加入集合(0表示不曾加入),再输出当前集合中x的个数,中间用空格格开。
输入
第一行是一个整数n,表示命令数。0<=n<=100000。
后面n行命令,如Description中所述。
输出
共n行,每行按要求输出。
样例输入
7
add 1
add 1
ask 1
ask 2
del 2
del 1
ask 1
样例输出
1
2
1 2
0 0
0
2
1 0
提示
Please use STL’s set and multiset to finish the task
查看 提交 统计 提问
额
挺简单的
直接上代码#include<bits/stdc++.h>
using namespace std;
int shu;``
void fuck(string m,int x) {
if(m==“add”)在这里插入代码片
{
`在这 s.insert(x);
cout<<s.count(x)<<endl;
} else if(m=="del") {
cout<<s.count(x)<<endl;//注意是if(s.count(x))j.insert(x);
s.erase(x);
} else if(m=="ask") {
if(j.count(x)!=0||s.count(x)!=0)cout<<"1"<<" "<<s.count(x)<<endl;//只要删除set或者删除后set里面任一个里面有就行`;
else cout<<"0"<<" "<<s.count(x)<<endl;
}
}int main()
cin>>shu;
while(shu--) {
string a;
int b;
cin>>a>>b;
fuck(a,b);
}
return 0;
}``操作前的
上一篇: Ugly numbers
下一篇: set四种排序方法
推荐阅读
-
ES6 逐点突破系列 -- Set Map
-
set_include_path用法
-
ini_set的用法介绍_PHP
-
mysql事务用begin……commit好还是用set autocommit……commit好
-
php set_magic_quotes_runtime() 函数过时解决办法
-
php set_time_limit(0) 设置程序执行时间的函数
-
PHP 特殊方法 __set()、__get()_PHP教程_编程技术
-
c/c++ 标准库 map set 删除
-
MySQL中SQL-TEXT、DATE和SET数据类型_MySQL
-
PHP中用set_time_limit(0)长连接的实现_PHP