欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Elevator( HDU - 1008 )

程序员文章站 2022-05-13 17:04:47
...

Vj 链接 C - Elevator(10p)

 来源:HDU - 1008 

Time limit :1000 ms               Memory limit :32768 kB

OS : Windows                        Source :ZJCPC2004

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. 

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled. 

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed. 

Output

Print the total time on a single line for each test case. 

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

Hint:题目并不难,主要是考虑下一次在同一楼层的时候,直接加5s。原本以为不需要加,结果一直WA。

代码如下:

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

using namespace std;

int main()
{
    long long n, a;
    while(~scanf("%I64d", &n) && n)
    {
        long long sum = 0, b = 0;
        while(n--)
        {
            scanf("%I64d", &a);
            if(b < a)
            {
                sum += (a - b) * 6 + 5;
                b = a;
            }
            else if(b > a)
            {
                sum += (b - a) * 4 + 5;
                b = a;
            }
            else if(a == b)
            {
                sum += 5;
            }
        }
        printf("%I64d\n", sum);
    }
    return 0;
}

 

相关标签: 杭电