Elevator( HDU - 1008 )
Vj 链接 C - Elevator(10p)
来源:HDU - 1008
Time limit :1000 ms Memory limit :32768 kB
OS : Windows Source :ZJCPC2004
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2 3 2 3 1 0
Sample Output
17 41
Hint:题目并不难,主要是考虑下一次在同一楼层的时候,直接加5s。原本以为不需要加,结果一直WA。
代码如下:
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;
int main()
{
long long n, a;
while(~scanf("%I64d", &n) && n)
{
long long sum = 0, b = 0;
while(n--)
{
scanf("%I64d", &a);
if(b < a)
{
sum += (a - b) * 6 + 5;
b = a;
}
else if(b > a)
{
sum += (b - a) * 4 + 5;
b = a;
}
else if(a == b)
{
sum += 5;
}
}
printf("%I64d\n", sum);
}
return 0;
}
推荐阅读
-
湫湫系列故事——设计风景线 HDU - 4514
-
HDU6315 Naive Operations(线段树 复杂度分析)
-
惠普Envy 4-1008tx可以加固态硬盘吗
-
【题解】hdu1506 Largest Rectangle in a Histogram
-
C - Monkey and Banana HDU 1069( 动态规划+叠放长方体)
-
HDU 1052(田忌赛马 贪心)
-
hdu-1338 game predictions(贪心题)
-
致初学者(四):HDU 2044~2050 递推专项习题解
-
C语言BFS--Find a way(Hdu 2612)
-
『ACM C++』HDU杭电OJ | 1425 - sort (排序函数的特殊应用)