欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

51Nod - 1019

程序员文章站 2022-05-11 17:03:56
...

利用归并排序求逆序对nlog(n).就是在排序过程中利用逆序对的性质,进行计数求和。

在一个排列中,如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个逆序。一个排列中逆序的总数就称为这个排列的逆序数。

如2 4 3 1中,2 1,4 3,4 1,3 1是逆序,逆序数是4。给出一个整数序列,求该序列的逆序数。

Input

第1行:N,N为序列的长度(n <= 50000) 第2 - N + 1行:序列中的元素(0 <= Aii <= 10^9)

Output

输出逆序数

Sample Input

4
2
4
3
1

Sample Output

4
//package p0208;
import java.util.*;
public class Main {
	static int ans=0;
	public static void merge(int[] a,int first,int mid,int end,int[] temp)
	{
		int i=first,j=mid+1,k=0;
		while(i<=mid&&j<=end)
		{
			if(a[i]<=a[j])
			{
				temp[k++]=a[i];
				i++;
			}
			else
			{
				temp[k++]=a[j++];
				ans+=mid-i+1;//计数求和
			}
		}
		while(i<=mid)
		{
			temp[k++]=a[i++];
		}
		while(j<=end)
		{
			temp[k++]=a[j++];
		}
		for(i=0;i<k;i++)
		{
			a[i+first]=temp[i];
		}
	}
	public static void mergesort(int[] a,int first,int end,int[] temp)
	{
		if(first<end)
		{
			int mid=(first+end)/2;
			mergesort(a,first,mid,temp);
			mergesort(a,mid+1,end,temp);
			merge(a,first,mid,end,temp);
		}
	}
	public static void sort(int[] a,int n)
	{
		int[] temp=new int[n];
		mergesort(a,0,n-1,temp);
	}
	public static void main(String[] args) {
			Scanner sc=new Scanner(System.in);
			int n=sc.nextInt();
			int[] a=new int[n+5];
			for(int i=0;i<n;i++)
			{
				a[i]=sc.nextInt();
			}
			sc.close();
			sort(a,n);
			System.out.println(ans);
			
	}

}

 

相关标签: java基础