PAT_B1004 | 成绩排名
程序员文章站
2022-05-11 09:08:51
...
1004 成绩排名 (20分)
读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。
输入格式:
每个测试输入包含 1 个测试用例,格式为
第 1 行:正整数 n 第 2 行:第 1 个学生的姓名 学号 成绩 第 3 行:第 2 个学生的姓名 学号 成绩 ... ... ... 第 n+1 行:第 n 个学生的姓名 学号 成绩
其中
姓名
和学号
均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。输出格式:
对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。
输入样例:
3 Joe Math990112 89 Mike CS991301 100 Mary EE990830 95
输出样例:
Mike CS991301 Joe Math990112
代码如下:
//
// Created by LittleCat on 2020/1/31.
//
#include <cstdio>
#define MAX 105
struct student {
int score;
char name[15];
char id[15];
} student[MAX];
int main() {
int t;
scanf("%d", &t);
int max = 1, min = 1;
for(int i = 1; i <= t; i++) {
scanf("%s %s %d", student[i].name, student[i].id, &student[i].score);
if(student[i].score < student[min].score)
min = i;
if(student[i].score > student[max].score)
max = i;
}
printf("%s %s\n", student[max].name, student[max].id);
printf("%s %s\n", student[min].name, student[min].id);
}
end
欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~
上一篇: 数据结构------顺序查找
下一篇: 在css样式中引入字体图标