POJ 1088 滑雪
程序员文章站
2022-05-08 23:50:20
...
POJ 1088 滑雪
描述
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长的滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。
输入
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
输出
输出最长区域的长度。
样例输入
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
样例输出
25
Code
#include <iostream>
#include <vector>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;
int row, col;
vector<vector<int>> m, dp;
int dx[] = { 1, -1, 0, 0 };
int dy[] = { 0, 0, 1, -1 };
int dfs(int r, int c)
{
if (dp[r][c] != -1) return dp[r][c];
int mxx = 0;
for (int i = 0; i < 4; i++)
{
int nr = r + dx[i], nc = c + dy[i];
if (nr >= 0 && nr < row && nc >= 0 && nc < col && m[nr][nc] < m[r][c]) mxx = max(dfs(nr, nc) + 1, mxx);
else mxx = max(1, mxx);
}
dp[r][c] = mxx;
return mxx;
}
int main()
{
scanf("%d%d", &row, &col);
m.resize(row, vector<int>(col, 0));
dp.resize(row, vector<int>(col, -1));
for (int i = 0; i < row; i++)
for (int j = 0; j < col; j++)
scanf("%d", &m[i][j]);
int ans = 0;
for (int i = 0; i < row; i++)
for (int j = 0; j < col; j++)
ans = max(dfs(i, j), ans);
printf("%d\n", ans);
return 0;
}
推荐阅读
-
POJ3252Round Numbers(数位dp)
-
kuangbin专题专题四 Frogger POJ - 2253
-
kuangbin专题 专题一 简单搜索 棋盘问题 POJ - 1321
-
kuangbin专题 专题一 简单搜索 Prime Path POJ - 3126
-
POJ:1017-Packets(贪心+模拟,神烦)
-
poj1637 Sightseeing tour(混合图欧拉回路)
-
POJ1862 Stripies 贪心 B
-
POJ2431 优先队列+贪心 - biaobiao88
-
微软悄悄调高Win10家庭版售价:涨价200元 现价1088元
-
滑雪初学者必知:冬季滑雪的七个注意事项