1029. Median (25)
程序员文章站
2022-05-04 15:31:35
...
一连几题都不觉得难,让我产生了一种我也很强的错觉。。。。。
这题就是简单的排序,自从学会用qsort之后觉得排序问题都弱爆了。
一开始没有留意到题目给出的两个数组已经有序的,我就将两个数组合成一个,然后直接qsort。这时犯了一个逗比的错误,我知道两个1000000会超过数组最大长度,不能直接a[1000000]定义,会出现段错误。要用malloc申请空间,逗比的我只对sque这样做了,Q1和Q2继续直接定义,还思考了一阵为什么会出现段错误。
另外,看答案之后,发现有序之后,改写了一下,直接一边排序一边输入到第三个数组。结果比qsort快了近100ms
暴力qsort
merge
1029. Median (25)
时间限制
1000 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
Given two increasing sequences of integers, you are asked to find their median.
Input
Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.
Output
For each test case you should output the median of the two given sequences in a line.
Sample Input
4 11 12 13 14
5 9 10 15 16 17
Sample Output
13
#include <stdio.h>
#include <stdlib.h>
#include<stdbool.h>
#define MAXLEN 2000010
typedef long int ElementType;
int myCmp(const void* a, const void* b)
{
return *(int *)a - *(int *)b;
}
void testPrint(ElementType a[], int len)
{
int i;
for(i=0; i<len; i++)
{
printf("%ld ", a[i]);
}
}
int main()
{
int numOfQ1, numOfQ2;
int total = 0;
int i, j;
//ElementType sque[MAXLEN];
ElementType *sque = (ElementType *)malloc(sizeof(ElementType)*MAXLEN);
scanf("%ld", &numOfQ1);
//ElementType Q1[numOfQ1];
ElementType *Q1 = (ElementType *)malloc(numOfQ1*sizeof(ElementType));
for(i=0; i<numOfQ1; i++)
{
scanf("%ld", &Q1[i]);
sque[total++] = Q1[i];
}
scanf("%ld", &numOfQ2);
//ElementType Q2[numOfQ2];
ElementType *Q2 = (ElementType *)malloc(numOfQ2*sizeof(ElementType));
for(i=0; i<numOfQ2; i++)
{
scanf("%ld", &Q2[i]);
sque[total++] = Q2[i];
}
qsort(sque, total, sizeof(sque[0]), myCmp);
// i = j = 0;
// while(i<numOfQ1 && j<numOfQ2)
// {
// if(Q1[i]<Q2[j])
// {
// sque[total++] = Q1[i++];
// }
// else
// {
// sque[total++] = Q2[j++];
// }
// }
// while(i<numOfQ1)
// {
// sque[total++] = Q1[i++];
// }
// while(j<numOfQ2)
// {
// sque[total++] = Q2[j++];
// }
//testPrint(sque, total);
int median;
if(total&1)
{
median = total/2;
}
else
{
median = total/2 - 1;
}
printf("%ld", sque[median]);
free(Q1);
free(Q2);
free(sque);
system("pause");
}
上一篇: eclipse使用外部 maven
下一篇: maven教程--结合eclipse
推荐阅读
-
重庆所有大学排名2021最新排名-重庆25所本科院校排名(含软科、校友会)
-
25个CSS3动画按钮和菜单教程分享
-
Python 25行代码实现的RSA算法详解
-
2021年江苏省转公办的独立学院名单汇总:江苏25所独立学院转设了吗?
-
为大家详细介绍25个Linux 服务器安全小技巧
-
2021江苏最佳十大独立学院-江苏各独立院校转设方案(25所院校全部情况)
-
分享下25个必须记住的SSH命令
-
25个好用的Shell脚本常用命令分享
-
剑指offer25:复杂链表(每个节点中有节点值,以及两个指针,一个指向下一个节点,另一个特殊指针指向任意一个节点),结果返回复制后复杂链表的head。
-
不止一亿像素 小米10主摄还能这样玩:25mm焦段景中带人