Power Strings
题目:
Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
分析:
题目介绍了一大堆看起来很唬人,但是只是要求循环节的出现的次数,用“Next 数组”公式就OK了,记得先进行判断是否是循环。
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
int Next[100000005];
char str[100000005];
void get_next(){
int len = strlen(str);
int j = 0, k = -1;
Next[0] = -1;
while(j < len){
if(k == -1 || str[j] == str[k]){
k++;
j++;
Next[j] = k;
}
else
k = Next[k];
}
}
/*
int kmp(){
int i = 0, j = 0;
while(i < a_len && j < b_len){
if(j == -1 || a[i] == b[j]){
i++;
j++;
}
else
j = Next[j];
}
if(j == b_len)
return i - j + 1;
else
return -1;
}
*/
int main(){
int t;
while(scanf("%s", str) && str[0] != '.'){
get_next();
int len = strlen(str);
if(len % (len - Next[len]) == 0)
cout << len/(len - Next[len]) << endl;
else
cout << "1" << endl;
}
return 0;
}
上一篇: xpath+bs4简单总结
下一篇: AJAX之POST数据中文乱码如何解决
推荐阅读
-
国外著名论坛程序IPB(Invision Power Board)在nginx下的配置示例
-
Highlight patterns within strings
-
详解linux中的strings命令简介
-
Python原始字符串(raw strings)用法实例
-
Python3.8中使用f-strings调试
-
chapter1:python 基础(数据类型,运算符,常用内置函数,模型,strings等)
-
android开发教程之获取power_profile.xml文件的方法(android运行时能耗值)
-
Mac应用程序的Power Nap功能如何关闭
-
A7VMX主板NB和SB POWER GOOD线路图
-
Go语言strings包