欢迎您访问程序员文章站本站旨在为大家提供分享程序员计算机编程知识!
您现在的位置是: 首页

Power Strings

程序员文章站 2022-05-02 17:36:52
...

题目:

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.


分析:

题目介绍了一大堆看起来很唬人,但是只是要求循环节的出现的次数,用“Next 数组”公式就OK了,记得先进行判断是否是循环。


代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int Next[100000005];
char str[100000005];

void get_next(){
    int len = strlen(str);
    int j = 0, k = -1;
    Next[0] = -1;
    while(j < len){
        if(k == -1 || str[j] == str[k]){
            k++;
            j++;
            Next[j] = k;
        }
        else
            k = Next[k];
    }
}

/*
int kmp(){
    int i = 0, j = 0;
    while(i < a_len && j < b_len){
        if(j == -1 || a[i] == b[j]){
            i++;
            j++;
        }
        else
            j = Next[j];
    }
    if(j == b_len)
        return i - j + 1;
    else
        return -1;
}
*/

int main(){
    int t;
    while(scanf("%s", str) && str[0] != '.'){
        get_next();
        int len = strlen(str);
        if(len % (len - Next[len]) == 0)
            cout << len/(len - Next[len]) << endl;
        else
            cout << "1" << endl;
    }
    return 0;
}