HDU -> ACM -> Pie
程序员文章站
2022-04-18 14:30:03
...
Pie
Time Limit : 5000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 32 Accepted Submission(s) : 19
Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.
What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.
Input
One line with a positive integer: the number of test cases. Then for each test case:---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.
Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
Sample Input
3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2
Sample Output
25.1327
3.1416
50.2655
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
double pi=acos(-1.0);
double pie[10010];
double sum,maxn;
int main()
{
int i,n,f,t,c,cnt;
double l,r,m;
//freopen("out.txt","r",stdout);
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&f);
f++;
maxn=sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&c);
pie[i]=pi*c*c;
maxn=max(pie[i],maxn);
sum+=pie[i];
}
l=maxn/f;
r=sum/f;
while(l+0.00001<r)
{
m=(l+r)/2;
cnt=0;
for(i=0;i<n;i++)
cnt+=(int)floor(pie[i]/m);
if(cnt<f) r=m;
else l=m;
}
printf("%.4lf\n",l);
}
return 0;
}
上一篇: Nginx和Apache比较
推荐阅读
-
【表格】大于号转义符>---小于号转义符<
-
Contest100000569 - 《算法笔记》2.5小节——C/C++快速入门-&amp;gt;数组
-
python如何提取js 内容 及遇到html转义符如何自动转义(pythoh3 ''&lt;abc&gt;' )
-
HTML转义字符,HTML字符实体< >: &
-
HTML<script>标签
-
C#List<T>排序多权重、自定义
-
.Net Core中使用ref和Span<T>提高程序性能
-
安装fc17后,mysql启动错误问题解决<转>
-
<转>mysql对于大表(千万级),要如何优化呢
-
MyBatis中 <sql>标签和<include>标签